Analyst Device Driver Software

Tutorial
Use the ADD Software ................................................................................................................. 5
  Configure the Devices in the Agilent LC Stack Automatically ................................................... 5
  Change the Agilent Sampler Temperature Mode (Thermostat Handling) ................................... 9
    For Constant Temperature Mode ....................................................................................... 12
    For Variable Temperature Mode ......................................................................................... 13
  Configure the CTC PAL3 Autosampler Automatically ............................................................... 14
  Configure and Activate the Hardware Profile ........................................................................... 20
    Hardware Profiles with Different Combinations of the ADD Software and Integrated Devices .......................................................................................................................... 23
  Assign Wellplates and Map Racks ........................................................................................... 27
    Assign Wellplates in the Agilent Autosampler ................................................................. 27
    Map Rack Positions for a CTC PAL3 Autosampler ............................................................. 30
  Create an Acquisition Method ................................................................................................. 36
  View the Acquisition Method in the Acquisition Method Editor ............................................. 40
  Modify Parameters for the LC Devices in the Acquisition Method ......................................... 42
  Create and Submit Batches for Data Acquisition ..................................................................... 44
  Verify the Status of Instrument, Devices connected to the Instrument, and Batch Acquisition .......................................................................................................................... 46
  View Devices Parameters Used for Acquisition in File Information of Data Files ..................... 49
  Create a Custom Plate Layout ................................................................................................. 50
  Use the Generic Agilent Autosampler and Generic Plates ..................................................... 60
  Use the LC Reference Vials .................................................................................................... 61
  Enable Recording of the Pressure Gradient ............................................................................ 62
  Use the Custom Injection Program ........................................................................................ 63

A Troubleshooting ..................................................................................................................... 65
  Control Software Waiting Indefinitely during Acquisition ....................................................... 65
  Software Application Status for the ADD Software is in Error and the Pump Turns Off at the End of a Sample ........................................................................................................ 66
  Control Software Goes to Error State during Acquisition ....................................................... 67
  Hardware Profile Activation Might Take Some Time After the LC Devices Configuration in the ADD Software ........................................................................................................ 68
  Cluster Partner Missing Error in the ADD Software ................................................................... 69
  LC Devices Show Error in the Status Dialog in the ADD Software ........................................... 71
  Batch Acquisition Stops when an Autosampler is used through the ADD software ................. 71
  Missing Vial and other Errors during a Batch Acquisition ....................................................... 72

Contact Us .................................................................................................................................. 75

Tutorial
GEN-IDV-05-13744-B
Analyst Device Driver Software
3/76
Use the ADD Software

The Analyst Device Driver (ADD) software is an LC device control application for the control software. It is based on Agilent Technologies Instrument Control Framework (ICF). Currently, the ADD software can be used to control the Agilent Technologies devices and PAL3 RTC and RSI autosamplers from CTC. The ADD software uses ICF components and interfaces to provide instrument configuration, method creation and editing, communication (Run Control) and status representation.

Note: The ADD software is designed to interface the control software with Agilent Instrument Control Framework, a new way to control newer LC devices. Most of the Agilent-related or CTC-related user interface shown within the ADD software are provided by Agilent or CTC. These interfaces are detailed within the documentation that comes with the device. Online Help is also available through the ADD software. Familiarize yourself with these documents before using the ADD software to avoid configuration issues. Note that the Agilent documentation refers to the use of Chemstation. ADD software can be substituted for Chemstation within these instructions.

In this guide, the term control software refers to the Analyst, Analyst MD, and the Analyst TF software.

Configure the Devices in the Agilent LC Stack Automatically

The various peripheral devices in an LC stack can be configured both automatically and manually. This procedure describes the automatic method.

When using an Agilent LC stack that includes pumps and an autosampler but does not include a DAD, connect the LAN from the computer to the pump and not to the autosampler.

1. Open the control software.
2. Make sure that the hardware profile is deactivated.
4. Select the networks that the Analyst Device Driver (ADD) software is allowed to communicate on and then click Allow Access. The Analyst Device Driver dialog opens.
Use the ADD Software

Figure 1 Analyst Device Driver Dialog

5. Click **Configure**.
   The LC Device Configuration dialog opens.

Figure 2 LC Device Configuration Dialog

6. In the left panel, select the type of Agilent LC system to be configured.
   All of the peripheral devices for each group of Agilent LC systems are listed under that group. Expand the group to view the list.
7. Click **Auto Configure**.
   The Automatic configuration parameters dialog opens.

8. Click either the IP **address** or the **Hostname** option.

9. Type either the IP address or the host name for the host computer. For more information, press **F1** to open the Agilent Help.
10. Click **OK**.
Auto Configure automatically detects the peripheral devices connected to the computer and lists them in the right panel in the LC Device Configuration dialog.

**Figure 5 LC Device Configuration Dialog**

11. To customize the settings of a peripheral device:
   a. In the right panel, double-click the device to be configured.
   b. Change the settings, if required.

**Tip!** To open the Agilent Help, click **Help**.

**Note:** Each Agilent pump can be assigned a unique name during configuration. The names are shown in the Instrument Control Method Editor, Status user interface, and File Info.

The dialog to configure the selected peripheral device opens.
12. Click **OK**.
13. Repeat step 11 and step 12 for all of the peripheral devices shown in the right panel.
14. Click **OK**.
15. Click the minimize button on the top right part of the Analyst Device Driver dialog.

### Change the Agilent Sampler Temperature Mode (Thermostat Handling)

1. Open the control software.
2. Make sure that the hardware profile is deactivated.
3. Turn on the LC devices, making sure that the thermostat module is available for the sampler.
5. Click **Configure**. The LC Device Configuration dialog opens.
6. Select Agilent 1100/1200/1260/1290 LC, click Auto Configure, and then type the IP address of the LC stack. All of the available modules, including the sample thermostat, are detected. The software reads the selected temperature mode from the LC stack. The default mode is Constant temperature mode (control setting).

**Note:** Do not change the mode in this configuration dialog.

7. Click OK and then save the LC configuration.

8. In the control software, activate a hardware profile containing the Analyst Device Driver (ADD) software.

9. In the ADD software, click Status.

10. In the Status Dashboard, right-click the autosampler tile, click Modify > Temperature Mode and then select the new Temperature Mode.
Figure 8 Status Dashboard

The new Temperature Mode is written to the LC stack. The Sampler module is shown as offline.

11. Deactivate the hardware profile.

12. Return to the ADD software, click Configure, and then click Clear to remove all of the LC devices in the right pane.

13. In the left pane of the LC Device Configuration dialog, select Agilent 1100/1200/1260/1290 LC, click Auto Configure, and then type the IP address of the LC stack. All of the LC modules, including the thermostat with the new assigned Temperature Mode, are detected.

14. In the control software, activate the hardware profile containing the ADD software again.

**Note:** When the Temperature Mode is changed, the LC devices must be configured again in the ADD software as described in steps 11 to 14.

**Note:** When the Temperature Mode is set to Constant temperature mode (control setting), the thermostat (shown as cooler) parameters are shown in the autosampler control screen, accessed from the Status Dashboard. When Temperature Mode is set to Variable temperature mode (method parameter), the thermostat (shown as cooler) parameters are shown in the autosampler Method Editor, which is accessed from the ADD method. Refer to the following figures.
For Constant Temperature Mode

Figure 9 Change Temperature Mode

![Change Temperature Mode](image)

Figure 10 Sampler Control screen in the ADD Status Dashboard

- **Cooler**
  - On
    - 25 °C
  - Off

Max. Temperature ≤ 5°C below ambient

Figure 11 Sample Method Editor

![Sample Method Editor](image)
For Variable Temperature Mode

Figure 12 Change Temperature Mode

![Change Temperature Mode](image)

Mode: Variable temperature mode (method parameter)
- Constant temperature mode (control setting)
- Variable temperature mode (method parameter)

Figure 13 Sampler Control Screen in the ADD Status Dashboard

<table>
<thead>
<tr>
<th>Missing Vessel</th>
<th>Illumination</th>
</tr>
</thead>
<tbody>
<tr>
<td>☐ Ignore missing vessel</td>
<td>On</td>
</tr>
<tr>
<td>☐ Off</td>
<td></td>
</tr>
</tbody>
</table>

At Power On

☐ Turn on Cooler

Automatic Turn On

☐ Turn on at [Date and Time]

Pump Connected to Sampler

G7120A:DEBAY000131

Clear Workspace

At End of Analysis
Configure the CTC PAL3 Autosampler Automatically

The PAL3 autosampler from CTC can be configured both automatically and manually. This procedure describes the automatic method.

**Note:** A sync cable, called the PAL connecting cable APG Remote, is used to connect the PAL3 autosampler to an Agilent pump when both the devices are configured through the Analyst Device Driver (ADD) software. The cable connects to the 15 pin INTERFACE connection on the back of the PAL3 autosampler and to the 9 pin REMOTE connection on the back of the Agilent pump.

1. Do one of the following:
   - If only a PAL3 autosampler is being configured using the ADD software, then continue with step 2.
   - If both Agilent devices and a PAL3 autosampler are being configured using the ADD software, then in the LC Device Configuration dialog where the Agilent devices were
configured in the section: Configure the Devices in the Agilent LC Stack Automatically, autoconfigure the PAL3 autosampler by performing steps 7 onwards in this procedure.

**Note:** Make sure to add the CTC PAL3 autosampler to the ADD software configuration before adding any other LC devices.

2. Open the control software.

3. Make sure that the hardware profile is deactivated.


5. Select the networks that the ADD software is allowed to communicate on and then click **Allow Access**. The Analyst Device Driver dialog opens.

**Figure 15 Analyst Device Driver Dialog**

![Analyst Device Driver Dialog](image)

6. Click **Configure**. The LC Device Configuration dialog opens.
7. If required, select **CTC Analytics LC** system in the left panel. Expand the CTC Analytics LC group to view the peripheral devices for that group.
8. Click **Auto Configure**.
   The Automatic Configuration Parameters dialog opens.

8. Click **Auto Configure**.
   The Automatic Configuration Parameters dialog opens.

9. Type either the IP address or the hostname for the host computer.
10. Click **OK**.
Auto Configure automatically detects the peripheral devices connected to the computer and lists them in the right panel in the LC Device Configuration dialog.

**Figure 19 LC Device Configuration Dialog with only the CTC PAL3 Autosampler Configured using the ADD Software**

11. Click CTC PAL3 in the right pane and then click **Configure**.
12. Click **Retrieve Configuration**.
**Figure 20 Retrieve Configuration**

Configure CTC PAL3 LC Sampler

![Connection Information](image)

<table>
<thead>
<tr>
<th>Connection Information</th>
</tr>
</thead>
<tbody>
<tr>
<td>IP Address or Hostname</td>
</tr>
<tr>
<td>Instrument Name</td>
</tr>
<tr>
<td>Firmware Version</td>
</tr>
<tr>
<td>Serial Number</td>
</tr>
</tbody>
</table>

**Note:** When adding or changing a CTC PAL3 autosampler configuration, or if there is an accidental physical interference with the autosampler, then **Retrieve Configuration** must be performed in the Configure CTC PAL3 LC Sampler dialog to retrieve the latest configuration. If the hardware profile is active during an accidental physical interference with the autosampler, then it must be deactivated and then activated again after the recovery Retrieve Configuration is successful.

13. If the Retrieve Configuration is successful, then click **Tray Configuration** if there were any changes made to the tray configuration as well.

14. Click **OK**.

15. If required, customize the settings of the PAL3 device in the right panel using the PAL terminal.

16. After the changes are completed, reconfigure the device using steps 7 to 14.

17. Select the appropriate Agilent devices from the left pane and then click **Auto Configure**. The Automatic Configuration Parameters dialog opens.

18. Type either the IP Address or the Hostname for the host computer and then click **OK**. Auto Configure automatically detects the peripheral devices connected to the computer and lists them in the right panel in the LC Device Configuration dialog.
19. Click **OK** in the LC Device Configuration dialog.

20. Click the minimize button on the top right part of the Analyst Device Driver dialog.

### Configure and Activate the Hardware Profile

1. On the Navigation bar, double-click **Hardware Configuration**. The Hardware Configuration Editor opens.

2. Click **New Profile**. The Create New Hardware Profile dialog opens.

3. Type a name in the **Profile Name** box.

4. Click **Add Device**. The Available Devices dialog opens.

5. Select **Mass Spectrometer** as the **Device Type**.

6. In the **Devices** section, select a mass spectrometer, and then click **OK**.
7. In the Create New Hardware Profile dialog, click **Setup Device** and configure the mass spectrometer as required. Refer to the control software document: *Help or System User Guide*.

8. Click **Add Device**.
   The Available Devices dialog opens.

9. Select **Software Application** from the **Device Type** list.
   Software Application is listed in the Devices section.

10. Click **OK**.

11. In the Create New Hardware Profile dialog, make sure that the Software Application entry is selected and then click **Setup Device**.
    The Software Applications Settings dialog opens. The **Analyst Device Driver** option is selected in the Software applications section.
Use the ADD Software

Figure 23 Software Application Settings Dialog

12. Select the required options and click **OK**. The Analyst Device Driver (ADD) is added to the current profile.

Figure 24 Create New Hardware Profile Dialog

13. Click **OK**. The new hardware profile is created.

14. With the newly created hardware profile selected, click **Activate Profile**.
Tip! If the hardware profile activates successfully, then set the Read Only attribute on the hwpf file, located in D:\Analyst Data\Projects\API Instrument\Configuration, to prevent accidental changes. Make sure to remove the Read Only attribute before editing the hardware profile.

15. Click Close.

Hardware Profiles with Different Combinations of the ADD Software and Integrated Devices

The Analyst Device Driver (ADD) software supports hardware profiles containing different combinations of Agilent, CTC, Shimadzu, ExionLC, and other devices connected using the ADD software or connected as integrated devices. Some examples of possible combinations of devices in a hardware profile are provided. Refer to the table: Table 1.

If a hardware profile contains some devices configured using the ADD software and some configured as an integrated device, then the integrated device is configured using the control software and the ADD-controlled device is configured using the ADD software.

Table 1 Examples of Possible Combinations of Devices Configured using the ADD Software or Configured as Integrated Devices in a Hardware Profile

<table>
<thead>
<tr>
<th>Devices configured using ADD</th>
<th>Devices configured as integrated devices</th>
</tr>
</thead>
<tbody>
<tr>
<td>PAL3 autosampler from CTC</td>
<td>DAD, Agilent pump, oven, and so on</td>
</tr>
<tr>
<td>DAD, Agilent pump, CTC PAL3 autosampler, oven, and so on.</td>
<td>N/A</td>
</tr>
</tbody>
</table>

Note: A sync cable, called the PAL connecting cable APG Remote, is used to connect the PAL3 autosampler to an Agilent pump when both of the devices are configured through the ADD software. Depending on the Agilent device, a sync cable is required between the CTC PAL3 device and pump. An ERI connector is required for Agilent 1260 Infinity II pumps and an APG connector is required for the Agilent 1290 pump.

<table>
<thead>
<tr>
<th>PAL3 autosampler</th>
<th>Shimadzu pump, column oven, PDA, UV Detector</th>
</tr>
</thead>
<tbody>
<tr>
<td>PAL3 autosampler</td>
<td>ExionLC pump, column oven, PDA, and so on</td>
</tr>
<tr>
<td>Agilent autosampler, Agilent pump, oven, DAD, and so on</td>
<td>N/A</td>
</tr>
</tbody>
</table>
Table 1 Examples of Possible Combinations of Devices Configured using the ADD Software or Configured as Integrated Devices in a Hardware Profile (continued)

<table>
<thead>
<tr>
<th>Devices configured using ADD</th>
<th>Devices configured as integrated devices</th>
</tr>
</thead>
<tbody>
<tr>
<td>Agilent autosampler</td>
<td>Agilent pump, oven, DAD, and so on</td>
</tr>
<tr>
<td>Agilent autosampler</td>
<td>Shimadzu pump, column oven, PDA, UV Detector</td>
</tr>
<tr>
<td>Agilent autosampler</td>
<td>ExionLC pump, column oven, PDA, and so on</td>
</tr>
<tr>
<td>Agilent pump, oven, DAD, and so on</td>
<td>PAL autosampler</td>
</tr>
<tr>
<td>Agilent autosampler</td>
<td>PAL autosampler; Agilent pump, oven, DAD, and so on</td>
</tr>
<tr>
<td></td>
<td><strong>Note:</strong> When multiple autosamplers are included in the hardware profile, only the last added autosampler is used for acquisition.</td>
</tr>
<tr>
<td>Agilent pump, oven, DAD, and so on</td>
<td>PAL autosampler; Shimadzu pump, column oven, PDA, UV Detector</td>
</tr>
<tr>
<td>Agilent pump, oven, DAD, and so on</td>
<td>PAL autosampler; ExionLC pump, column oven, PDA, and so on</td>
</tr>
</tbody>
</table>

Create a Hardware Profile with Different Combinations of ADD and Integrated Devices

As an example, the following procedure describes the steps to create a hardware profile that contains a mass spectrometer, Agilent pump and column oven as integrated devices, and the CTC PAL3 autosampler as a device controlled by the Analyst Device Driver (ADD) software. The procedure also describes creating an acquisition method for such a hardware profile.

1. In the ADD software, autoconfigure the CTC PAL3 autosampler. Refer to the section: Configure the CTC PAL3 Autosampler Automatically.
2. Create a hardware profile in the control software and then activate it. Refer to the control software document: Help and the section: Configure and Activate the Hardware Profile.
3. Open the Acquisition Method Editor.

4. Set the Synchronization Mode to Manual/AAO Sync.

5. Provide the parameter values for the mass spectrometer, pump, and the column oven. Refer to the control software document: Help.

6. Save the acquisition method.

7. Maximize Analyst Device Driver window and then click Method to update PAL3 parameters using the ADD software.
8. Select a script from the Select Method Script list. Refer to the PAL3-specific section: Create an Acquisition Method.

9. Update the parameter values for the PAL3 autosampler as required. Refer to the PAL3-specific section: Create an Acquisition Method.

10. To save the parameter values for the peripheral devices in the same method that was created in step 6, click File > Save to Analyst .dam file. The Save Method dialog opens.

11. Select the method that was created in step 6, and then click Save.

12. Click Yes in the Confirm Save As dialog. The parameter values for the PAL3 are saved in the same method that was created in step 6.

13. Click File > Exit.

14. Open the acquisition method in the control software and then click Analyst Device Driver in the left pane in the Acquisition Method Editor. The parameters for the CTC PAL3 autosampler are shown in the Software Application Properties tab.
Assign Wellplates and Map Racks

Some devices might need to be further configured, such as assigning wellplates in Agilent autosamplers, resetting the injector, and mapping racks in the PAL3 autosampler. For such configuration, use the Status mode in the Analyst Device Driver (ADD) software.

The Status mode enables the user to configure the connected devices directly.

**Tip!** If a hardware profile is already configured for the peripheral devices in an LC stack and after that the devices are further configured using the Status mode, then those devices must be automatically configured again using the ADD software. First deactivate the hardware profile and then automatically configure the devices. Refer to the section: Configure the Devices in the Agilent LC Stack Automatically or Configure the CTC PAL3 Autosampler Automatically.

Assign Wellplates in the Agilent Autosampler

1. Click **Status** in the Analyst Device Driver dialog.
Use the ADD Software

Figure 29 Analyst Device Driver Dialog

The Status dialog opens.

Figure 30 Status Dialog

2. To open the menu to control the autosampler, right-click in the Multisampler pane.

Tip! To use the menu to control other devices, right-click in the pane for that device.

Note: The autosampler might not automatically detect which plates are placed inside the autosampler trays.
3. To view the plates that are currently available, move the cursor over the plate picture in the Multisampler status pane.
4. To change the plates, right-click in the Multisampler status pane and then click **Assign Wellplates**.

5. Select the required plates and then click **OK**.

**Map Rack Positions for a CTC PAL3 Autosampler**

1. Click **Status** in the Analyst Device Driver dialog.
2. Right-click in the PAL3 pane.
The right-click menu opens.
4. Map the rack positions in the dialog to the rack positions in the autosampler.
Note: Make sure that this same mapping is used in the Sample tab and Locations tab when a batch is created in the Batch Editor in the control software. Refer to the CTC PAL3 section: Create and Submit Batches for Data Acquisition.

5. Click **OK**.

6. Right-click in the **PAL3** field and then click **Show Script Manager**. The PAL3 Scripts dialog opens.
7. Click **Import Scripts**.
8. Navigate to the folder where the PAL3 scripts are stored.

**Tip!** On computers configured with the Windows 10, 64-bit operating system, browse to the folder: `C:\Program Files (x86)\AB SCIEX\AnalystDeviceDriver\CTCScripts`.

The folder contains seven PAL3 scripts:

- LC Injection.xml
- LC MS Fast Injection.xml
- LC MS Standard Injection.xml
- LC Injection_AllLSTools_DeepNdl.xml
- LC Injection_SwitchVLV_TransferTime_DeepNdl.xml
- LC MS Fast Injection_1or2valve_DeepNdl.xml
- LC MS Standard Injection_1or2valve_DeepNdl.xml

9. Click the required script file. For example, select **LC Injection.xml**.
Use the ADD Software

The imported script is shown in the PAL3 Scripts dialog.

Figure 40 PAL3 Scripts Dialog

![PAL3 Scripts Dialog]

**Note:** A script must be imported only once if the same hardware configuration is used. If a hardware change is made in the PAL3 autosampler, for example if a new drawer or a tool is added, then we recommend configuring the PAL3 autosampler again using the **Configure** option in the ADD, and then checking for the presence of the selected script in the Instrument Control Method Editor. Refer to step 7 in the section: Create an Acquisition Method. If the script is not listed in the Instrument Control Method Editor, then import it again.

10. Click **OK**.

Create an Acquisition Method


2. On the Acquisition Method Properties tab, click **Manual/AAO Sync** in the Synchronization Mode field.
3. For the mass spectrometer, provide the values for the different parameters on the MS and Advanced MS tabs. Refer to the control software document: Help.

4. Click File > Save.

5. Maximize the Analyst Device Driver dialog.

6. Click Method.

   The Instrument Control Method Editor opens. The editor contains one tab for each peripheral device that was configured in the LC Device Configuration dialog.

**Figure 41 Unsaved Method Dialog (Agilent Devices)**
7. (For the CTC PAL3 device) Select a script from the **Select Method Script** list. Scripts provide a predesigned template of parameters for the CTC PAL3 devices. If a customized template of parameters is needed, then contact SCIEX support at sciex.com/request-support.

Parameters for the selected script are shown.

**Figure 43 Parameters for the Selected Script LC Injection**
**Note:** Each script installed with the Analyst Device Driver (ADD) software is designed for a specific tool.

- **LC Injection:** To be used only when using a standard syringe tool (for example, D7/57, D8/57) and wash module (for example, Fast Wash). Do not use this script when using the LCMS Tool and LCMS Wash module.

- **LCMS Standard:** To be used only when LCMS-P Tool and LCMS Wash are installed.

- **LCMS Fast:** To be used only when LCMS-P Tool and LCMS Wash are installed. This script is different than the Standard version. This script does not contain an outside needle wash that speeds up the wash process. If carryover is an issue, then use the LCMS Standard script.

- **LC Injection_ALLLSTools_DeepNdl:** To be used with the RTC model to support all available LS tools with deeper needle penetration enabled.

- **LC Injection_SwitchVLV_TransferTime_DeepNdl:** To be used for online solid phase extraction (SPE). This script supports a switching valve, has a transfer time field, and has deeper needle penetration enabled.

- **LC MS Fast Injection_1or2valve_DeepNdl:** To be used with the LCMS-P Tool. This script supports up to two valves and has deeper needle penetration enabled.

- **LC MS Standard Injection_1or2valve_DeepNdl:** To be used with the LCMS-P Tool. This script supports up to two valves and has deeper needle penetration enabled.

8. Modify the values of the parameters for the peripheral devices, as required. For more information, press **F1** to open the Agilent Help or the CTC Help.

9. To save the parameter values for the peripheral devices in the same method that was created in steps 2 and 3, click **File > Save to Analyst .dam file**.

**Figure 44 File Menu**

<table>
<thead>
<tr>
<th>File</th>
<th>View</th>
</tr>
</thead>
<tbody>
<tr>
<td>Open from Analyst .dam file</td>
<td></td>
</tr>
<tr>
<td>Save</td>
<td></td>
</tr>
<tr>
<td>Save to Analyst .dam file</td>
<td></td>
</tr>
<tr>
<td>Exit</td>
<td>Alt+F4</td>
</tr>
</tbody>
</table>

**Tip!** The **File > Save** menu option can also be used to save the parameter values in the same method that was created in steps 2 and 3.

The Save Method dialog opens.

10. Select the method that was created in steps 2 and 3, and then click **Save**.
Use the ADD Software

11. Click **Yes** in the Confirm Save As dialog. The parameter values for the peripheral devices are saved in the same method that was created in steps 2 and 3.

12. Click **File > Exit**.


**View the Acquisition Method in the Acquisition Method Editor**

1. In the control software, on the Navigation bar, under **Acquire**, double-click **Build Acquisition Method**.

2. Open the method that was created in the previous section. The method opens and Analyst Device Driver (ADD) software application is shown in the Acquisition Method pane.

![Figure 45 Analyst Device Driver in the Acquisition Method Editor](image)

3. Click **Analyst Device Driver**. The configuration details for the devices configured using the Analyst Device Driver is shown in the Software Application Properties tab.
Figure 46 Configuration Details for the Devices (for Agilent devices)
Modify Parameters for the LC Devices in the Acquisition Method

1. On the Navigation bar, under Companion Software, double-click Analyst Device Driver. The User Account Control dialog opens, asking if the Analyst Device Driver (ADD) software should be allowed to make changes to the computer.

2. Click Yes. The Analyst Device Driver dialog opens.
3. Click **Method**.
The Instrument Control Method Editor opens.

4. Click **File > Open from Analyst .dam file**.

**Figure 48 File Menu**

<table>
<thead>
<tr>
<th>File</th>
<th>View</th>
</tr>
</thead>
<tbody>
<tr>
<td>Open from Analyst .dam file</td>
<td></td>
</tr>
<tr>
<td>Save</td>
<td></td>
</tr>
<tr>
<td>Save to Analyst .dam file</td>
<td></td>
</tr>
<tr>
<td>Exit</td>
<td>Alt+F4</td>
</tr>
</tbody>
</table>

The Load Method dialog opens.

5. Click the method to open and then click **Open**.

6. The peripheral devices portion of the selected acquisition method opens in the Instrument Control Method Editor.

7. Make the required changes.

8. Click **File > Save**.

**Figure 49 File Menu**

<table>
<thead>
<tr>
<th>File</th>
<th>View</th>
</tr>
</thead>
<tbody>
<tr>
<td>Open from Analyst .dam file</td>
<td></td>
</tr>
<tr>
<td>Save</td>
<td></td>
</tr>
<tr>
<td>Save to Analyst .dam file</td>
<td></td>
</tr>
<tr>
<td>Exit</td>
<td>Alt+F4</td>
</tr>
</tbody>
</table>

The changes are saved into the open acquisition method.

9. If required, click **File > Save to Analyst .dam file** to save the peripheral devices configuration in a different acquisition method.

**Figure 50 File Menu**

<table>
<thead>
<tr>
<th>File</th>
<th>View</th>
</tr>
</thead>
<tbody>
<tr>
<td>Open from Analyst .dam file</td>
<td></td>
</tr>
<tr>
<td>Save</td>
<td></td>
</tr>
<tr>
<td><strong>Save to Analyst .dam file</strong></td>
<td></td>
</tr>
<tr>
<td>Exit</td>
<td>Alt+F4</td>
</tr>
</tbody>
</table>

The Save Method dialog opens.
Use the ADD Software

10. Select an acquisition method, and then click **Save**.
    The Confirm Save As dialog opens.

11. Click **Yes**.
    The parameter values for the peripheral devices are saved in the acquisition method
    selected in step 10.

12. Click **File > Exit**.

Create and Submit Batches for Data Acquisition

Using the methods created in this guide, create and submit batches to acquire data. Refer to the
control software document: *Help*.

If the Agilent Infinity II Multisampler is used, then in the **Locations** tab in the Batch Editor,
right-click and select **Multi Drawer** to view the new layout of Agilent Infinity II Multisampler.

Figure 51 New Layout of the Agilent Infinity II Multisampler in the Locations Tab

The Agilent Infinity II Multisampler device being used might contain fewer drawers and plates
than are shown in the preceding figure. The layout in the Locations tab shows the maximum
number of drawers and plates possible. When configuring the plates on the Locations tab, start
from the bottom of the multi-drawer layout and then proceed up.

When the CTC PAL3 autosampler is used to create a batch in the control software, make sure
that the rack mapping in the Sample tab and the Locations tab matches the rack mapping that
was performed in step 4 in the section: *Map Rack Positions for a CTC PAL3 Autosampler*. The
rack mapping in the following figures matches the rack mapping that was done in step 4 in the
section: *Map Rack Positions for a CTC PAL3 Autosampler*. 
Figure 52 Sample Tab in the Control Software Batch Editor—Rack Mapping for CTC PAL3

Figure 53 Locations Tab in the Control Software Batch Editor—Rack Mapping for CTC PAL3

**Note:** For batch submission and acquisition, there is no validation on the rack and plate type between the batch and autosampler configuration if the autosampler is controlled using the Analyst Device Driver (ADD) software. Users must make sure that the same rack and plate are selected in the batch as configured for the autosampler in the ADD software.
Use the ADD Software

Note:

The ADD software does not directly support column indexing for the CTC PAL3. To use column indexing for batch acquisition, use the hand-held pilot to add a new plate with column indexing, and use the `RackBuilder.exe` utility to add a custom plate with the same column indexing to the control software Autosampler Database. Make sure that the indexing is in sync between the CTC PAL3 and the control software. The following steps can be followed:

1. Start `RackBuilder.exe` by right-clicking and then clicking Run as administrator. Refer to the section: Create a Custom Plate Layout.
2. Add a new plate with a specific indexing by row or by column using the `RackBuilder.exe` utility.
3. Add the same plate with the same layout and orientation using the PAL3 handheld pilot.
4. Configure PAL3 in the ADD software. Click Tray Configuration and then select the new custom plate.
5. After activating the hardware profile, click ADD Status UI.
6. Right-click on PAL3 and then click Show Rack Position Mapping.
7. Make sure that the mapped rack contains the new custom plate. Refer to the section: Map Rack Positions for a CTC PAL3 Autosampler.

Verify the Status of Instrument, Devices connected to the Instrument, and Batch Acquisition

2. In the Analyst Device Driver dialog, click Status. The Status dialog opens. The dialog shows the status of the peripheral devices connected to the mass spectrometer and the computer. The dialog also shows if the mass spectrometer is switched on, is offline, or is idle.
3. Click ?? to open the Agilent Help. Refer to the figure: Figure 54.

4. Click ?? to open the PAL3 Help. Refer to the figure: Figure 55.

5. Click ?? to open a dialog to view information about the Agilent devices connected to the mass spectrometer and the computer. Refer to the figures: Figure 56 and Figure 57.
6. In right bottom corner of the control software, double-click the **Analyst LC** status icon. The Software Application Status dialog, including both Brief Status and Detailed Status for the Analyst Device Driver (ADD) software, is shown.
Figure 58 Software Application Status Dialog

View Devices Parameters Used for Acquisition in File Information of Data Files

Open a data file acquired with the acquisition methods created in this document.


2. In the Data Files pane, select the wiff file to view.

3. In the Samples pane, select the sample to view and then click OK. The data acquired from the sample opens.

4. To view the file information, click Show File Info (¶). The File information pane opens below the graph.

5. Expand the Log Info section.
Use the ADD Software

Information about the Analyst Device Driver (ADD) software and the peripheral devices connected to the mass spectrometer and configured is shown in the right pane of the File Information pane.

6. Expand the Acquisition Info section in the left pane of the File Information pane. The parameters and their values for each peripheral device used during data acquisition are shown in the right pane of the File Information pane.

Create a Custom Plate Layout

Users can create a plate layout that is not currently available in the plate list. If a similar plate (for example, a plate with the same layout and same number of vials, by row or by column) already exists in the list of generic plates, then a new plate does not need to be created using the RackBuilder.exe utility and the user should continue with step 24.

1. Close the control software.

2. Do one of the following:
   - For computers configured with the Microsoft Windows 7, 32-bit operating system, browse to the C:\Program Files\Analyst\bin\ folder.
   - For computers configured with the Microsoft Windows 7, 64-bit operating system, browse to the C:\Program Files (x86)\Analyst\bin\ folder.
   - For computers configured with the Microsoft Windows 10, 64-bit operating system, browse to the C:\Program Files (x86)\Analyst\bin\ folder.

3. Create a backup copy of the following files and then store them in a safe location on the local drive so that they can be restored if required:
   - AutosamplerDB.adb
   - AutosamplerDBServer.adb

4. Right-click RackBuilder.exe and then click Run as administrator. The Open POET Database dialog opens.

Figure 59 Open POET Database Dialog
5. In the **Database** field, select **AutosamplerPoetDB** and then click **OK**. The Autosampler Database dialog opens.

**Figure 60 Autosampler Database Dialog**

6. In the **Autosampler** field, select **Agilent Autosampler**.

7. In the **Plate** section, click **New**. The New Plate dialog opens.

**Figure 61 New Plate Dialog**
Use the ADD Software

8. In the field provided, type the name of the new plate in the following format:
   - \( rcVialGenPlateR \), where \( r \) equals the number of rows in the plate, \( c \) equals the number of columns in the plate, and \( R \) indicates that the vials are ordered by row, OR
   - \( rcVialGenPlateC \), where \( r \) equals the number of rows in the plate, \( c \) equals the number of columns in the plate, and \( C \) indicates that the vials are ordered by column.

   For example, in the name \( 6\times9VialGenPlateR \) indicates a 54-vial plate, with 6 rows and 9 columns.

9. Click OK.
   The Plate Editor (Agilent Autosampler) dialog opens.

**Figure 62 Plate Editor (Agilent Autosampler) Dialog**

10. Remove the \( u_\) at the front of the plate Name.
    By default, the name of the plate is automatically preceded by \( u_\).

11. Click Plate Layout.
    The Vial Layout Information dialog opens.
12. In the **Horizontal Plate Size** field, type the number of columns in the plate.

   **Tip!** For the example plate name provided in step 8, type 9 in this field.

13. In the **Vertical Plate Size** field, type the number of rows in the plate.

   **Tip!** For the example plate name provided in step 8, type 6 in this field.

14. (Optional) Select the appropriate **Header Type** from the list provided.
   Options include **No Header**, **Alphanumeric A1 TopLeft**, **Alphanumeric A1 BottomLeft**, **Numeric Top**, and **Numeric Left**.

15. (Optional) Select the appropriate **Vial Shape** from the list provided.
   Options include **Circular** and **Rectangular**.

16. Click **Next**.
   The Vial Layout dialog opens.
17. Do one of the following to populate all of the vial positions in the table:

- Click **Single** and then click inside each of the vial positions to add the vial numbers, one at a time.
- Click **Row** and then click inside the first vial position of the row to add all of the vial numbers for the corresponding row.
- Click **Column** and then click inside the first vial position of the column to add all of the vial numbers for the corresponding column.

**Tip!** If an error is made, then click **Remove Selections**. This removes all of the information in the table.

18. Click **Finish**.
    The Plate Editor (Agilent Autosampler) dialog opens.

19. Click **OK**.
The Autosampler Database dialog opens. The new plate is shown in the **Plate** list.

20. In the **Rack** section, select the appropriate rack for the plate and then click **Edit**. The Rack Editor (Agilent Autosampler) dialog opens.

**Figure 65 Rack Editor (Agilent Autosampler) Dialog**

21. In the **Plates used with this rack** list, select the check box corresponding to the new plate.

22. Click **OK**. The Autosampler Database dialog opens.

23. Click **OK**.

24. Open the control software.

25. On the Navigation bar, under **Companion Software**, double-click **Analyst Device Driver**.
Use the ADD Software

The Analyst Device Driver dialog opens.

26. Click **Configure**.
    The LC Device Configuration dialog opens.

27. Select the autosampler to be configured in the right panel and then click **Configure**.
    The Configure (selected) Sampler dialog opens.
28. Click **Define Sample Containers**.

The Define and edit Wellplates dialog opens.
29. Click **Add**.
   The Edit Wellplate dialog opens.
30. Type the name of the added plate in the **Plate Name** field.

31. Update all of the fields in the Edit Wellplate dialog with the appropriate information.
   
   All of the fields in the **Row information**, **Column information**, **Well information**, and **Plate information** sections must be updated with the information for the plate.

32. Click **OK**.
   The plate is added to the first line of the table on the Define and edit Wellplates dialog.
33. Click **OK**.
   The plate is added and can now be selected in the **Location** tab of the control software Batch Editor.

### Use the Generic Agilent Autosampler and Generic Plates

The user assigns a plate using the Analyst Device Driver (ADD) Status user interface in Direct Mode. Right-click on the autosampler status user interface, select **Assign Wellplates**, and then select a plate that matches the plate in the autosampler drawer. In the control software Batch Editor, select a generic plate that contains the same number of rows and columns. The single plate racks (10×10, 4×10 and 3×5) are still available. However, the following new plate list is available for the 2 Wellplates and Multi Drawer rack types:

- 15VialGenPlateC
- 24VialGenPlateR
- 27VialGenPlateC
- 384VialGenPlateC
- 384VialGenPlateR
- 54VialGenPlateC
- 54VialGenPlateR
- 6VialGenPlateC
Use the ADD Software

- 96VialGenPlateC
- 96VialGenPlateR

**Note:** The suffix letter represents the vial, numbered by column ('C') or numbered by row ('R'). For example, in the progressive count on the 6VialGenPlateC, A-1 represents vial 1, B-1 represents vial 2, and so on. In the progressive count on the 24VialGenPlateR, A-1 represents vial 1, A-2 represents vial 2, and so on. For all of the plates, the origin (A-1) is on the top left.

1. In the control software Batch Editor, create a batch.
   
   **Note:** During the installation of the ADD, the autosampler database is updated with a generic Agilent Autosampler profile. When the ADD is part of the hardware profile, the Agilent Autosampler is automatically selected in the Batch Editor Locations tab, regardless of the model available in the LC stack.

2. On the Locations tab, click inside the appropriate drawer and then right-click to access the list of available plates.

3. Select the plate that matches the plate (number of vials) in the autosampler.
   
   **Note:** When an Agilent autosampler is used in a batch, the following rack codes and autosamplers are available:

<table>
<thead>
<tr>
<th>Rack Code</th>
<th>Agilent Autosampler Type</th>
</tr>
</thead>
<tbody>
<tr>
<td>Multi Drawer</td>
<td>Multisampler</td>
</tr>
<tr>
<td>2 Drawer Plates</td>
<td>Vialsampler</td>
</tr>
<tr>
<td>2 × 50Vial Drawer</td>
<td></td>
</tr>
<tr>
<td>2 Wellplates</td>
<td>All the other Agilent Autosamplers</td>
</tr>
<tr>
<td>10 By 10</td>
<td></td>
</tr>
<tr>
<td>4 By 10</td>
<td></td>
</tr>
<tr>
<td>3 By 5</td>
<td></td>
</tr>
</tbody>
</table>

**Use the LC Reference Vials**

When the Analyst Device Driver (ADD) software is installed, only the plates that are #VialGenPlateC or #VialGenPlateR contain five additional vials, referred to as the LC reference vials. These vials are typically shown to the right of the standard vials with the numbering starting at 20001 to 20005.

1. Create a batch in the control software.
Use the ADD Software

2. Set the sample locations on the Batch Editor Locations tab.

Figure 70 Batch Editor Locations Tab

3. To use the LC reference vials, select the appropriate vials in the order that they are to be analyzed.

Enable Recording of the Pressure Gradient

1. Open the control software.


3. Click Configure. The LC Device Configuration dialog opens.
4. Select the **Enable Real-Time Monitoring** check box. During acquisition, the pump pressure data is captured in the wiff file.

5. To view the pressure date, open the wiff file in the control software, right-click inside the TIC pane and then select **Show ADC data** from the list of options. The pressure trace is shown.

### Use the Custom Injection Program

This program provides a method to automatically add an internal standard to any vial before injection.

1. Open the control software.


3. Click **Method**. The Instrument Control Method Editor dialog opens.

4. Click the **Custom Injector** tab.
5. Press **F1** to access information about working with this tab, if required.
Occasionally, during acquisition, the control software might go in the waiting state, generate an error, or seem to be waiting indefinitely for some action but the cause of these issues might not be clear. To help troubleshoot these occurrences, some possible causes are described in this section.

For more troubleshooting information, refer to the Agilent Help.

**Tip!** All of the events, including errors, warnings, and other messages, that are generated about the Analyst Device Driver (ADD) software are logged in the Event Log. To open the Event Log, in the control software, click **View > Event Log**. Under **Windows Logs**, double-click **Application**. For more information, refer to the *Filtering the Event Log* topic in the control software document: **Help**.

**Tip!** Another log, specific to the ADD software, is located in the `<drive>:\ProgramData\AB SCIEX\AnalystDeviceDriver\Log` folder.

**Tip!** To troubleshoot the cause of an issue, show detailed status information by moving the cursor over the status description in the Status dialog.

**Control Software Waiting Indefinitely during Acquisition**

During acquisition, the control software might seem to be waiting indefinitely for the sample injection to happen. In this case, as shown in the following figure, the front door of the autosampler might be open. After the front door is closed properly, the control software resumes acquisition.
Troubleshooting

Figure A-1 Front Door Open Message

Software Application Status for the ADD Software is in Error and the Pump Turns Off at the End of a Sample

If there is no sync (remote) cable between the CTC PAL3 autosampler and the Agilent pump, the current sample will finish, the software Application Status for the Analyst Device Driver (ADD) software in the control software will go to Error state, and the pump will be turned off. Refer to the figure: Figure A-2. To recover, connect the sync cable between the CTC PAL3 autosampler and the pump, and then deactivate the hardware profile, and activate it again.
During acquisition if the control software goes to Error state, as shown in the following figure, and the Status dialog in the Analyst Device Driver (ADD) software also shows an error, then move the cursor on the red Error rectangle in the Pump pane and the error message will show the cause of the error. Refer to the figure: Figure A-4. There might be a leak in the pump.
To resolve this issue, do the following:

1. Deactivate the hardware profile in the control software.
2. Turn off the device.
3. Fix the leak in the pump.
4. Turn on the device.
5. Activate the hardware profile.
6. Start the acquisition again.

**Hardware Profile Activation Might Take Some Time After the LC Devices Configuration in the ADD Software**

After the LC devices are configured using the Analyst Device Driver (ADD) software and the hardware profile is created in the control software and activated, the device activation might take some time. During this time, the control software status bar shows the Wait status for the ADD software. This is because the LC devices might still be initializing. This can be checked by moving the cursor over the grey **Offline** rectangle in the Status dialog. The message will show that the devices are initializing. Refer to the figure: Figure A-5. After the initialization is complete, the hardware profile is activated.
Cluster Partner Missing Error in the ADD Software

If the initial pump in the LC stack is changed with another one, then during the hardware profile activation, the status bar in the control software might show that the Analyst Device Driver (ADD) software does not come out of the equilibration mode. This issue occurs because the autosampler in the LC stack is not able to find the pump to which it is connected. View the cause of the error in the Status dialog. Refer to the figure: Figure A-6. When the cursor is moved over the yellow Not Ready rectangle in the Multisampler pane, the error message shows that the cluster partner is missing, which means that the autosampler is not able to find the pump to which it is connected.
To fix this issue, do the following:

1. In the Status dialog, right-click in the autosampler pane and click **Control**.
   The Control dialog opens.

2. From the list in the **Pump Connected to Sampler** field, select the pump to which the autosampler is connected.
LC Devices Show Error in the Status Dialog in the ADD Software

If any of the LC Devices shows error in the Status dialog, then a red light is lit on the actual devices too, which indicates that the device is in an error state.

Figure A-8 LC Devices in Error State

To clear the error state, do the following procedure.

1. Deactivate the current hardware profile in the control software.
2. Turn off the devices showing error.
3. Turn on the devices again.
4. Activate the hardware profile again.

Batch Acquisition Stops when an Autosampler is used through the ADD software

When an autosampler is used through the Analyst Device Driver (ADD) software, sometimes sample acquisition in a batch could stop. This could happen if the racks in the ADD software are not mapped correctly to the positions of racks and plates in the autosampler. For the CTC PAL3 autosampler, make sure that the rack mapping in the PAL3 Rack Position - Mapping dialog in the ADD software is mapped correctly to rack positions in the autosampler. Refer to the Map Rack Positions for a CTC PAL3 Autosampler. For an Agilent autosampler, refer to Assign Wellplates in the Agilent Autosampler.
Another reason for the batch to stop acquiring could be a missing vial in the rack.

**Missing Vial and other Errors during a Batch Acquisition**

During a batch acquisition, if a sample acquisition is aborted but the batch acquisition continues to the next sample, then the possible cause of the error is a missing vial. Refer to the figure: Figure A-9. Double-click the aborted sample to open a dialog that provides detailed information about the error. Refer to the figure: Figure A-10.

**Note:** In case of a missing vial, the batch acquisition will stop completely if the **Fail whole batch in case of missing vial** option is selected in the Queue Options dialog.

---

**Figure A-9 Aborted Sample Acquisition in Batch Editor**

![Figure A-9 Aborted Sample Acquisition in Batch Editor](image)

---

**Figure A-10 Sample Details Dialog — Details about the Error Missing Vial**

![Figure A-10 Sample Details Dialog](image)
If a sample acquisition is aborted during acquisition and the batch acquisition stops after that sample, then the possible cause could be anything. Refer to the figure: Figure A-11. Double-click on the aborted sample to open a dialog that provides detailed information about the error. Refer to the figure: Figure A-12. If the sample details just lists the error as method aborted, then open the Event Log to view detailed information about the error. Refer to the figure: Figure A-13

**Figure A-11 Aborted Sample Acquisition in Batch Editor**

![Aborted Sample Acquisition in Batch Editor](image)

**Figure A-12 Sample Details Dialog — Details about the Error Method Aborted**

![Sample Details Dialog](image)
Figure A-13 Event Log — Details about the Error Method Aborted

![Event Log Screenshot](image-url)
Contact Us

Customer Training

- In North America: NA.CustomerTraining@sciex.com
- In Europe: Europe.CustomerTraining@sciex.com
- Outside the EU and North America, visit sciex.com/education for contact information.

Online Learning Center

- SCIEX Now Learning Hub

SCIEX Support

SCIEX and its representatives maintain a staff of fully-trained service and technical specialists located throughout the world. They can answer questions about the system or any technical issues that might arise. For more information, visit the SCIEX website at sciex.com or contact us in one of the following ways:

- sciex.com/contact-us
- sciex.com/request-support

CyberSecurity

For the latest guidance on cybersecurity for SCIEX products, visit sciex.com/productsecurity.

Documentation

This version of the document supercedes all previous versions of this document.

To view this document electronically, Adobe Acrobat Reader is required. To download the latest version, go to https://get.adobe.com/reader.

To find software product documentation, refer to the release notes or software installation guide that comes with the software.

To find hardware product documentation, refer to the Customer Reference DVD that comes with the system or component.

The latest versions of the documentation are available on the SCIEX website, at sciex.com/customer-documents.
Note: To request a free, printed version of this document, contact sciex.com/contact-us.