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Foreword 1

Note: This guide contains the scripts for all instruments and different software versions. To
determine which scripts the software version installed on your instrument supports, refer to the
Analyst software release notes.

Audience

This guide is intended for customers and Field Service Employees (FSEs).

Note on Use

Scripts make the access to and use of the Analyst software easier. In regulated and controlled
operations, do not use scripts to replace traditional processes and workflows. For example, do
not use scripts to create methods, to make sure that system performance and data quality is
satisfactory, or to create reports.

Analyst Software Scripts User Guide
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Scripts p.

This document explains how to install and use Analyst software scripts. It also provides an
overview of the uses of each script and how to uninstall a script, if required.

Note: This guide contains the scripts for all instruments and different software versions. To
determine which scripts the software version installed on the instrument supports, refer to the
document: Release Notes for the Analyst software.

Install or Uninstall Scripts

Some scripts are automatically installed when the Analyst software is installed.
The remaining scripts are available in the Scripts folder.

Scripts must be installed to use them. Refer to the section: Install a Script.

Install a Script

1. Do one of the following:

* Browse tothe C:\Program Files (x86)\Analyst\Scripts folder on the
computer.

* Browse to the Extras\Scripts folder on the software DVD, if available, or in the
unzipped software web download package.

2. Open the Scripts folder.
3. Do one of the following:
* For the sMRM Calculator script, double-click sMRM Calculator Setup.exe.

» For all of the other scripts, double-click ScriptRunner.exe.

4. Follow the on-screen instructions to install the scripts.
The installed scripts are available from the Script menu.

Note: For some scripts, users can hold down the Shift key while accessing a script from the
Script menu to view a description of the script.

Uninstall a Script

Note: Do not uninstall the DFTTracker and MRM3 Optimization scripts. If these scripts are
removed, then the Analyst software must be installed again to get access to these scripts.

Scripts User Guide Analyst Software
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» To uninstall a script, do these steps as applicable:

For processing scripts, browse to the <drive>:\Analyst Data\Projects\API
Instrument\Processing Scripts folder, and then delete the script dll, or, if
applicable, the exe and bmp files, manually.

For the Create Quan Methods From Text Files, Create Text File from Quant Method,
and MSServicelog scripts, browse to the <drive>:\Analyst Data\Projects\API
Instrument\Processing Scripts folder and then delete the script dil manually.

For the sMRM Calculator script, do this:

a. Click Start > Control Panel > Programs and Features.
b. Right-click sMRM Calculator and then click Uninstall.
c. Obey the on-screen instructions.

For acquisition scripts, browse to the <drive>:\Analyst Data\Projects\API
Instrument\Acquisition Scripts folder, and then delete the script dll, or, if
applicable, the exe and bmp files, manually.

Add Missing Zeros

Use this script to add an intensity value of zero for the missing mass values in the spectrum. To
minimize storage requirements and to show and process data faster, the Analyst software does
not store or show spectral points with an original intensity of zero. If required, for example, when
exporting a spectrum for subsequent processing by custom software, these data points can be
added back to the spectrum.

Use the Script

* Click the spectrum and then click Script > Add Missing Zeros.
The script addd the zero values to all missing masses in the current spectrum.

Add Normalized ADC Traces

Use this script to overlay the active chromatogram or chromatograms with normalized ADC
data from a corresponding data file. Run the script when a pane containing one or more
chromatograms is active in Explore mode. There might be a time region selected in a trace.
If no selection is made, then the entire chromatogram is overlayed.

If the wiff file contains several ADC traces, then all of them will be shown.

Note: If the data in the active pane came from several samples, then the ADC data for the
sample corresponding to the first data set, not the active data set, is shown.

Analyst Software Scripts User Guide
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Use the Script

* Do one of the following:

» Click Script > AddNormalizedADC.

» To view the script description and add ADC data to an active Explore pane, hold the Shift
key down and click the script.

Analyst 1.2 Peak Finder Parameters

The Analyst software uses an improved version of Peak Finder for better peak detection and
ion abundance measurement. When the Peak Finder algorithm is used to analyze wiff files that
were acquired using the Analyst software, then use this script to set the peak finder algorithm
parameters.

Note: This script is installed automatically when the Analyst software is installed. There is no
separate installation program for it.

Tip! Browse to the Analyst Data\Projects\API Instrument\Processing Scripts
folder and make sure that the Analyst12PeakFinderParams.dll is present.

Use the Script

1. Click Script > Analyst12PeakFinderParams.
The Analyst 1.2 Peak Finder Algorithm Parameter dialog opens.

2. To activate the Analyst 1.2 version of Peak Finder, select the Use Analyst 1.2 peak finder
algorithm for Analyst 1.2 files check box.

3. Do the following:

* In the Intensity Threshold (%) field, type the value, as a percentage, of the minimum
intensity required to distinguish between noise and peak.

* In the Centroid Height (%) field, type the value, as a percentage, to be used by the
centroiding algorithm to find the peak and to determine the centroid m/z value at this
percentage height.

* In the Centroid Peak Width (min) field, type the minimum value, in ppm, to be used by
the centroiding algorithm to find the peak width and to determine the centroid m/z value
at this width.

* In the Centroid Peak Width (max) field, type the maximum value, in ppm, to be used by
the centroiding algorithm to find the peak width and to determine the centroid m/z value
at this width.

Scripts User Guide Analyst Software
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* In the Centroid Merge Distance (amu) field, type a value, in amu, to be used to
determine whether two centroid peaks should be merged in to one. If two peaks are
within this tolerance, then they are merged.

* In the Centroid Merge Distance (ppm) field, type a value, in ppm, to be used to
determine whether two centroid peaks should be merged in to one. If two peaks are
within this tolerance, then they are merged.

4. Click OK.

To return to the Analyst 1.4.1 Peak Finder algorithm, clear the Use Analyst 1.2 peak finder
algorithm for Analyst 1.2 files check box.

Change All Methods

It is often necessary to change the ion source conditions of a method. This script modifies every
method in a selected project with new values for lonSpray Voltage (IS), lon Source Gas 1 (GS1),
and Interface Heater Temperature (IHT).

Note: This script is used with any QTRAP® system. It is not used by QSTAR systems.

Use the Script
1. Click Script > ChangeAllMethods.

Figure 2-1 Change All Methods Dialog

=. Change All Methods =

Change all methodsz in the project;

I Example j

— Source Parameters

+ -

7 lonSpray Yaolkage [15] |'| 700 |-'I 700

v lon Source Gas 1(G51] |5 5

I Interface Heater Temperature [IHT] |'| oo |'| 0o

r update method with current ingtrument settings [AF3+EXB+C2R]

Cancel

2. Select a project containing the methods to be modified.

3. Select the parameters to be changed.

Analyst Software Scripts User Guide
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If the parameter is not in the method file, then it is ignored.
4. Type a value for positive experiments.
Type a value for negative experiments.

6. Select the update method with current instrument settings check box to change the
AF3, EXB, and C2B parameters for all of the methods in the selected project.

7. Click Change All.

Convert Methods

Use this script to convert methods from one type of instrument to another. The script converts
the method to the currently active hardware profile, using appropriate values for each parameter.
Only the ion source- and compound-dependent parameters for mass ranges and experiments
are shown.

The Convert Methods script automatically optimizes mass ranges and, in addition to single
period, single experiment methods, converts multiple periods, multiple experiments, and IDA
criteria.

Install the Script

1. Browsetothe C:\Program Files (x86)\Analyst\Scripts\Convert Methods
folder and then double-click Convert Methods Setup.exe.

2. Obey the on-screen instructions.

Use the Script

Make sure a hardware profile is active.

1. Click Script > Convert Methods.

Scripts User Guide Analyst Software
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Figure 2-2 Convert Methods Dialog

Convert Methods O] x]
Original Method m Convert: Converted Method m
Instrument: | 3200 Q TRAP Agquisition method Instrument: | QTRAP 5500
= | i ReserpineMSMS.dam = g <Not Saved=
= 4 Mass Spec = 4 Mass Spec
Bl (3 Peried 1 B (&) Peried 1
B 5 Product lon & §# Product lon
Mass Range 1582.00-18 = Mass Range 182.00-1
0P = DP
= EP =EP
=» CEP = CE
=) CE ) CXP
= CXP = i lon Source
= | lon Source = CUR
e CUR 18
=15 =) TEM
= TEM ) GS1
 GS1 = G52
mp G52 = CAD
Ep»ihe
mp CAD
OIS D OIS D

2. Click Open, browse to the method to be converted, and then click Open.
The Method Converter dialog shows the instrument name of the original method.

3. Click Save, type a name for the converted method, and then click Save.

Create Quantitation Methods and Text Files

The Create Text File From Quan Method script exports a quantitation method to a tab-delimited
text file. The Create Quan Method From Text Files script imports the information contained in

a tab-delimited text file to a Quantitation Method File (gmf). Currently, the Build Quantitation
Method component in the Analyst software does not support this functionality.

The Create Text File from Quan Method script creates a text file representation of a quantitation
method file. A column for each required field is created in the text file if the Export all columns

check box is selected. If the check box is not selected, then the script generates the text file with
columns only for the fields where the field value is not the same for all peaks.

Analyst Software Scripts User Guide
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The Create Quan Method From Text Files script specifies default values for any of the non-
required fields in the text file such as integration algorithm or regression parameters. For more
information, refer to the section: Text File Format .

Use the Create Quan Methods From Text Files Script
1. Click Script > Create Quan Methods From Text Files.

Figure 2-3 Create Quantitation Methods from Text Files Dialog

-

B Create Quantitation Methods from Text Files ﬁ1
Delault Genenc Farameters
Algonthm: j.Anulyst Classic (TurboChrom) vl_
Extraction Type: -MRM -] Feriog: 1 | Expenment: ['l ~|
Expectzd AT 01 min R Windowe 30 ‘sec [[)Use Fielative AT
Bkg Stari(min) 0 Bkg End (min) 0 |
Conc. Units Calc. Canc. Units:

Default Anahyst Classic (TurboChrom) Parameters
Bunching Factor: :'I - MNoise Threshold: | Aren Threshold: 200
Murn. Smooths D - Separation Width: . Separation Height  0.01
Exp. Peak Ratio: 5 Exp. Adjusted Ratio; | Exp. Walley Rafio: 3

Default General IntelliCuan Parameters Default IntelliCuan MO |l Parameters

Min. Peak Height 0 ops Moisa Percent 50
Min. Peak Width: 0 38C Base. Sub. Window: 1

Srmoathing YWdth; :U v._pcnrﬂs Peak-Spliting Factor. :2

Feport Largest Paak

Regrassion Parameters Default Window Summation Parameters

Fit Linear v |Use Baselina Subirachon

Weighting: Mone

Pararneter Arga Create One Method J
lterate: INn ]

Create Muliple Methods ]

2. Use the parameters in the Default Generic Parameters section to create a quantitation
method. The Algorithm, Extraction Type, Period, and Experiment fields are not available
in the Analyst software. Set the following parameters as required:

* From the Algorithm list, select a peak-finding algorithm. The Window Summation
algorithm sums all the intensities in the retention threshold and will not find any peaks.

* From the Extraction Type list, select the type of data that will be integrated.

Scripts User Guide Analyst Software
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* From the Period and Experiment lists, select the period number and experiment
number.

The Default Analyst Classic Parameters, Default General IntelliQuan Parameters, Default
IntelliQuan MQ Il Parameters, and the Default Window Summation Parameters groups
contain the parameters that are used by the algorithm selected in the Algorithm field.

Note: The Smoothing Width field in the Default General IntelliQuan Parameters group is
half the smoothing width.

3. Select the Use Baseline Subtraction check box to have the Window Summation algorithm
sum the intensities to the horizontal line at the minimum intensity of the data points within
the summation window, as opposed to summing down to the intensity zero.

4. In the Regression Parameters section, select the regression information.

The information specified here is applied to every analyte peak. Unlike the previous
parameters, it is not possible to indicate this information in the text files. Therefore, the
same regression parameters are applied to all analytes. For a full description of the
parameters, refer to the document: Help.

5. To create one quantitation method, click Create One Method, browse to the text file that will
be used to create the quantitation method, and then click Open.
A quantitation method gmf file with the same file name as the txt file is created if the text file
is in the correct format and contains the required columns. The created quantitation method
is stored in the Quantitation Methods folder under the current working project in the
Analyst software, regardless of the location of the text file.

6. To create multiple methods from multiple text files, click Create Multiple Methods, browse
to the folder where the text files are located, and then click OK.

A quantitation method gmf file with the same file name as the txt file is created for each
individual text file in that folder if they are in the correct format and contain the required
columns. The created quantitation methods are stored in the Quantitation Methods
folder under the current working project in the Analyst software, regardless of the location of
the text files.

Use the Create Text File from Quan Method Script

1. Create and save a quantitation method in the Analyst software.
2. Click Script > Create Text File from Quan Method.

Analyst Software Scripts User Guide
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Figure 2-4 Options Dialog

-

[5 Options

-

= =] %

Export all columns
(otherwise only iffield value is not the same for all peaks)

Only shawe this dialog again if the contral key is down

Ik, | ‘ Cancel

Select the Export all columns check box and then click OK.

4. Browse to and then select the quantitation method (gmf) file.

Navigate to and then select the location of the text file.
The script generates the text file with all columns. If the Export all columns check box was
not selected in step 3, then the script only generates the text file with columns for the fields
where the field value is not the same for all peaks.

Text File Format

The text files used to create the quantitation methods (Create Quan Methods from Text Files)
and generated from the methods (Create Text File from Quan Method) are in the following

format:

» Separate the various fields with tab characters and end each line with a carriage return or line

feed character.

» The first row of the file should contain column headings. All of the columns shown in the
following table marked as Required must be present. The remaining columns are optional.
The actual order of the columns is not important.

» Each subsequent line should contain the information as shown in the table for either one

analyte or an internal standard peak.

Table 2-1 Text File Formats

Column Name Required Description
Peak Name Yes The name of the analyte or internal standard peak.
First Mass Yes For MRM data, the Q1 mass for the peak. For full-scan

MI or Q3 MI data, the mass.

data, the starting mass for the XIC to integrate. For Q1

Scripts User Guide
RUO-IDV-05-0270-F
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Table 2-1 Text File Formats (continued)

Column Name

Required

Description

Second Mass

Maybe

This field is required when integrating full-scan or MRM
data, but not for Q1 Ml or Q3 MI data. For MRM data,
this is the Q3 mass for the peak. For full-scan data, it is
the ending mass for the XIC to integrate.

Extraction Type

No

The type of data to integrate. If present, this should be
one of:
0 - MRM data

1-Q1 Ml or Q3 Ml data

2 - full-scan data

Is IS

No

Specifies whether the current peak is an internal
standard or an analyte. TRUE if the peak is an internal
standard. Otherwise, FALSE. If this column is not
present, then all peaks defined are assumed to be
analytes.

Note: Internal standard peaks should be defined first in
the text file before any analyte peaks that use that IS.

IS Name

No

For analyte peaks, specifies the name of the
corresponding internal standard (if any). If a given
analyte will not use an internal standard, then leave the
contents of this field empty. For internal standard peaks
themselves, the contents of this field are ignored.

Period

No

The period number for the peak (from 1 to the number
of periods in the data).

Experiment

No

The experiment number for the peak (from 1 to the
maximum number of experiments in the period).

Use Relative RT

No

For analyte peaks that are using an internal standard,
specifies whether or not the expected retention time is
relative to that of the IS. TRUE if so. Otherwise, FALSE.
The contents of this field are ignored for other peaks,
but must still contain either TRUE or FALSE.

Conc Units

No

The concentration units.

Calc Conc Units

No

The calculated concentration units.

Analyst Software
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Table 2-1 Text File Formats (continued)

Column Name Required Description

Bkg Start No Start time, in minutes, for the peak background. This
parameter does not affect the peak integration in any
way, however, it does affect how the noise, and hence
S/N, is calculated.

Bkg End No End time, in minutes, for the peak background.

Expected RT No The expected retention time, in minutes, from 0 to
1666.

RT Window No The retention time window, in seconds, from 1 to 1000.

Algorithm No Specifies which peak-finding and integration algorithm
should be used. If present, this should be one of:
0 - Analyst Classic (TurboChrom)
1 - IntelliQuan - IQA 1l (Automatic)
2 - IntelliQuan - MQ Il
3 - Window Summation

Bunching Factor No (TurboChrom algorithm) The bunching factor for the
peak, from 1 to 100.

Num Smooths No (TurboChrom algorithm) The number of smooths, from
0to 10.

Noise Threshold No (TurboChrom algorithm) The noise threshold, from 1-6
to 19.

Area Threshold No (TurboChrom algorithm) The area threshold, from 1-6 to
112.

Separation Width | No (TurboChrom algorithm) The separation width, from 0 to
5.

Separation Height |No (TurboChrom algorithm) The separation height, from 0
to 1.

Exp Peak Ratio No (TurboChrom algorithm) The exponential peak ratio,
from 1 to 16.

Exp Adjusted Ratio [ No (TurboChrom algorithm The exponential adjusted ratio,
from 2 to 16.

Exp Valley Ratio No (TurboChrom algorithm) The exponential valley ratio,

from 1 to 16.

Scripts User Guide
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Table 2-1 Text File Formats (continued)

Baseline Sub

Column Name Required Description

Min Height No The minimum allowed peak height, from 0 to 116, when
using the IntelliQuan algorithm.

Min Width No (IntelliQuan algorithm) The minimum allowed peak
width, from 0 to 116, in seconds.

Smooth Width No (IntelliQuan algorithm) The half-width of the Savitzky-
Golay smoothing filter, from 0 to 20.

MQ Ill Noise No (IntelliQuan algorithm) The noise percentage when the

Percent MQ Il option is used. This should be an integer from, 0
to 100.

MQ Il Baseline No (IntelliQuan algorithm) The baseline subtraction

Sub Window window, from 0 to 10 minutes, when the MQ Il option is
used.

MQ Il Peak No (IntelliQuan algorithm) The peak-splitting factor, from 0

Splitting Factor to 10, when the MQ Il option is used.

MQ Il Use Largest | No (IntelliQuan algorithm) Specifies whether the largest
peak when the MQ Il option is used, within the
retention time window, or the peak whose retention time
is closest to that expected is reported. TRUE to use the
largest peak and FALSE to use the closest.

Summation No (Special window summation algorithm) Specifies

whether the area should be integrated to the intensity=0
line or to the intensity value of the least intense data
point within the window. TRUE if area should be
integrated to the intensity value of the least intense
data point, otherwise, FALSE if the area should be
integrated to the intensity=0 line.

The following table shows an example text file for full-scan data. The text file contains tabs
between the columns and a carriage return at the end of each line.

Table 2-2 Example Text File for Full-Scan Data

Peak Name First Mass Second Mass Bunching Factor
Analyte Peak 1 500.7 1
Analyte Peak 2 813 2

Analyst Software
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Table 2-2 Example Text File for Full-Scan Data (continued)

Peak Name First Mass Second Mass Bunching Factor

Analyte Peak 3 400 401 3

The following table shows another example for MRM data. The Analyte Peak 1 is configured to
use the specified internal standard and Analyte Peak 2 does not use an internal standard.

Table 2-3 Example Text File for MRM Data

Peak Name Is IS IS Name First Mass Second Mass
IS Peak 1 TRUE — 500.1 413.2
Analyte Peak 1 FALSE IS Peak 1 600.2 382.1
Analyte Peak 2 FALSE IS Peak 1 400 3121

The following table contains a mixture of full-scan and MRM data in different experiments:

Table 2-4 Example Text File for MRM Data

Peak Name Extraction Type Experiment First Mass Second Mass
Analyte Peak 1 0 1 500.1 413.2
Analyte Peak 2 0 1 600.2 382.1
Analyte Peak 3 2 2 812 813
Analyte Peak 4 2 2 400 401

Define Custom Elements

Use this script to select a custom isotope pattern when radio-labeled compounds are used. An
experiment-specific element pattern is used in the data interpretation in conjunction with the
Analyst software calculators or the Metabolite ID application.

The custom isotope patterns are kept together with the information from the periodic table
elements in the element definition file, SAElements.ini, which is located the folder: C: \Program

Files (x86)\Analyst\bin

In the element definition file, the custom elements must have a unique symbol and an atomic
number of 104 or higher.

Scripts User Guide Analyst Software
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Notes on Use

When the script is launched for the first time, a backup copy of the SAElements.ini file is saved
in the API Instrument folder. If required, the edited SAElements.ini file can be replaced with this
file in the folder: C: \Program Files (x86)\Analyst\bin

Update the Element Definition File Successfully

1. Do not open the SAElements.ini file in another text editor program while using the software.

2. Make sure that the file properties are set to read/write.

Edit the Define Custom Elements Table

The custom element table cannot be edited in the dialog. After the element definition file is
updated, the custom elements can be used with the Analyst software calculators.

1. Click Script > DefineCustomEl.

Figure 2-5 Define Custom Elements Dialog

2. Inthe table, click the row containing the element.

Analyst Software Scripts User Guide
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Figure 2-6 Define Element Dialog
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3. Edit the fields and then click OK.

4. To save the updated element definition file and exit the program, click OK.

View the Custom Element Symbol, Custom Element Name,
and Custom Pattern

+ To view the custom pattern in the mass/relative intensity graph, in the Define Custom
Elements dialog, click Show.

The Isotopic Distribution dialog opens.

The total of the individual isotope abundances for an element stored in the element definition
file must equal to one. Therefore, the abundances entered in the Define Element dialog

are rescaled before they are added to the Define Custom Elements dialog. This Isotopic
Distribution dialog cannot be edited. Zoom in on the area of interest by dragging along the
corresponding X- or Y-axis region.

The application requires the gen01.wiff example file to show custom patterns. If the
gen01.wiff file is not in the Example folder in the Analyst Data\Projects folder, the software
prompts the user to find this file.

Delete Others

Use this processing script to delete all panes except for the active one.

Scripts User Guide Analyst Software
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Use the Script

1.

With a sample file (wiff) with multiple panes open, click a pane.
The pane becomes the active pane.

Click Script > DeleteOthers.
All of the panes except for the active one are deleted.

DFT Tracker

The Dynamic Fill Time (DFT) Tracker script tracks the DFT settings used during QTRAP
instrument scans. Use the script to determine the optimal fill time for linear ion trap (LIT) mode to
obtain high data quality over a wide dynamic range. The DFT Tracker monitors the following LIT
scan types: Enhanced MS (EMS), Enhanced Resolution (ER), Enhanced Product lon (EPI), and
MS/MS/MS (MS3).

Use the Script

Click Script > DFTTracker.

Figure 2-7 Dynamic Fill Time Tracker Dialog
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DFT Tracker monitors the dynamic changes occurring during a real-time run.

The system dynamically calculates the time required to fill the linear ion trap. For abundant
compounds, a short fill time reduces the space charge effects by limiting the number of ions
in the ion trap. On the other hand, the longer fill time increases weak signals by allowing the
ions to accumulate.

Analyst Software Scripts User Guide
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Export IDA Spectra

Use this script to export data in a format that can be searched using a third-party application.
The Export IDA Spectra script exports every dependent product spectrum from an IDA
(Information Dependent Acquisition) LC/MS run to a series of text files. These text files can
then be submitted and searched using Sequest. The export is optimized so that any spectra
in adjacent cycles with the same precursor m/z value are combined in a single spectrum.
This optimization also applies to spectra with the same precursor but which reside in different
experiments, most likely using different values of the collision energy.

The charge state of the precursor ion is a required input. Sequest tries to automatically
determine this from the isotope spacing at the precursor m/z value in the IDA survey spectrum.
Note that while this determination is usually correct, it is not always.

Use the Script

It is assumed that the first experiment of the IDA method represents the survey spectrum and
that all of the other experiments represent dependent product spectra. Therefore, this script
cannot be used if there are multiple survey experiments.

1. With an IDA chromatogram in an active pane, click Script > Export IDA Spectra.

Figure 2-8 Export IDA Spectra (in Sequest Format) Dialog
[ Export IDA Specira (n Sequest Format) 3]

Mazs tolerance for combining MS/MS spectra: ID.1 arnu

M S/MS intenzity threzhold: |2

Mirirmum number of M55 ions for export: |5

[~ Separate values in output with a space, not a tab

[~ Use' ' and not " to delimit parent méz in *dta filename

Cloze |

2. Inthe Mass tolerance for combining MS/MS spectra field, type the tolerance to be used
to determine if two precursor m/z values should be considered identical.

If the precursors for two sequential product spectra differ by less than this value, then the
spectra are added and a single text file is exported.

3. Inthe MS/MS intensity threshold field, type the threshold that is applied to each product
spectrum after it is centroided. It is assumed that peaks below this threshold are most likely
noise. Type 0 in the field to exclude a threshold.

Scripts User Guide Analyst Software
RUO-IDV-05-0270-F 23/80



Scripts

In the Minimum number of MS/MS ions for export field, type the minimum number of ions
that must be present in a product spectrum, after centroiding and thresholding, for a text file
to be exported.

If a spectrum does not contain the specified number of ions, then it is assumed that the
quality of the spectrum is too low to merit exporting.

(Optional) To separate fields in the output files with a space character, select the Separate
values in output with a space, not a tab check box.

Otherwise a tab character is used. Some versions of Sequest require a space delimiter.

To export the text files, click Go.
The Save As dialog opens.

Type a location and root file name for the exported text files.

Before being exported to a text file, each of the product spectra is centroided. The cycle
number range and charge state is appended to this file for each exported spectrum.

Export Sample Information

Use this script to extract sample information, such as the name, sample ID, comment, and
acquisition method name for all samples in the wiff file. Define the information to be exported,
and the script saves the information in an inf file located in the same folder as the wiff file.

Use the Script

1.

2.

With a chromatogram or spectrum in an active pane, click Script >
ExportSamplelnformationFromMultipleSampleinOneWiff while pressing Ctrl.

Figure 2-9 Export Sample Information Dialog

i, Export Sample Information E3
— Export

[~ Full = wiff path ;
[~ Shart * wiff narme Cancel |
[~ Sample Mame

I Sample ID

[~ Comment

[ Acquisition Method Mame

Select the check boxes that correspond to the information to be exported and then click OK.
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Export to JCamp

Use the Analyst software to export graph data to a tab-delimited text file that can be read by
most applications. However, some applications require a more specific format.

Use the Export to JCAMP script to export graph data in the JCAMP format. The script works on
both chromatograms and spectra. For chromatograms, depending on the number of selections
made, either all of the spectral data of the chromatogram is exported, or the averaged sum of
the selected regions is exported. If this script is used on a single spectrum, then only that data
is exported. This script can also be attached to a batch so that the export occurs automatically
after the sample is acquired.

The following table shows an overview of the operation of the script. When run interactively the
exact behavior depends on the active Analyst software data.

Table 2-5 Script Operation

Modes Active data Operation

Interactive Spectrum The user is prompted for the name
of the JCamp file and the active
spectrum exported to it.

Interactive Chromatogram with two or more The user is prompted for the name
selections of the JCamp file and an averaged
spectrum corresponding to each of
the selections of the chromatogram
exported to it.

Interactive Chromatogram with one or no The user is prompted for the name of
selections the JCamp file and every spectrum
for the run exported to it.
Batch N/A The name of the JCamp file is

generated by appending the sample
number to the name of the wiff

file and changing the extension to
jdx. Every spectrum for the run

is exported to the JCamp file.

For multiple period/experiment data,
a separate file is exported for

each experiment. The period and
experiment numbers are appended
to the filename.

Use the Script
1. To use the Export to JCAMP do one of the following:
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* With either a chromatogram or a spectrum in an active pane, click Script > Export to
JCAMP.

* In the Batch Editor dialog, type 2Analyst Data \API Instrument\Processing
Scripts\Export to Jcamp.dll intheBatch Script field.

Figure 2-10 JCAMP Options Dialog
oGmpopos K|
Intenzity Threshold: Im—

v Centoid Exported Spectrd
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[~ Only show this dialog again if the control key is down

QK. | Cancel |

2. To select the centroiding options, do one of the following:

» Select the Centroid Exported Spectra check box to centroid the spectra before
exporting to the JCAMP format.

» To show the JCAMP Options dialog only if the Ctrl key is pressed when the script is
clicked from the Script menu, or when the batch is submitted to the queue, select the
Only show this dialog again if the control key is down check box.

To continue processing and to export the spectra, click OK.

4. When prompted, type the file name of the exported JCAMP file.

When a script is attached to the batch, the file name is automatically generated using the
following format: [WiffFileName]_[Sample#]_[Period#]_[Experiment#].jdx.

IDA Trace Extractor

Use this script to review the survey data collected using Information Dependent Acquisition (IDA)
based on the information in the corresponding dependent data. The script searches the MS/MS
data for given neutral losses or fragments and then calculates the Extracted lon Chromatograms
(XICs) for the precursor masses, which give the specified losses or fragments. The XICs are
overlaid in Explore mode and their peaks are labeled with the precursor mass. Refer to the
following figure.

Analyst Software Scripts User Guide
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Figure 2-11 Characteristic Traces in Dependent Experiment and XICs of the Survey
Experiment

Note: The characteristic m/z 387.1 detected in negative mode was converted to m/z 389.1 in the
positive survey scan.

Use the script to do the following:

Specify a list of expected fragments or neutral losses, in either the positive mode polarity, the
negative mode polarity, or both, in terms of fragment formula or mass.

Save the list of masses and fragments for a compound class and then load them to the
settings at a later time.

Process just a selected time region in the chromatogram.

Show precursor (survey scan) or fragment (dependent scan) XIC traces that yield a given
fragment or neutral loss.

* From the survey scan chromatograms, the user can link to any survey scan spectra.
» From the dependent scan traces, the user can link to any dependent scan spectra.

Reduce the precursor XIC traces to show only peaks that have corresponding neutral losses
or fragments.

Save the precursor mass list in a text file for further processing. Build the list of precursors
from a set of samples.
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» Save the list of masses in a format that can be loaded to the XICfromTable script.

» Save the list of masses and peaks in a format that can be loaded to the
CreateQuantMethodFromText script.

Note: The script is compatible with MRM/MIM IDA data and with the Analyst software.

Note: The script supports parallel data processing from positive and negative experiments.
Multiple survey and dependent experiments of any polarity can be used.

Use the Script

Note: The Analyst software version for a specific file can be shown in the file properties >
comments.

Process a full chromatogram or just a selected region. Make a selection before running the
script.

1. With a chromatogram (or selection) of IDA data open in an active pane, click Script >
IDATraceExtractor.

Figure 2-12 IDA Trace Extractor Dialog
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To continue, proceed to Neutral Losses or Fragments
tab oruse Tools menu.

2. In the Options tab, set the field values as required.
For more information, refer to the section: IDA Trace Extractor Tabs and Menu Parameters.

Analyst Software Scripts User Guide
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3. To store the retention times and precursor masses found during processing, open the
Results tab, type a file name, and then select Save Precursor Information.

Figure 2-13 IDA Trace Extractor Dialog: Results Tab
rEl IDA Trace Extractor ﬁﬁ
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4. To review or enter the mass information, open the Neutral Losses or Fragments tab. Type
the neutral losses and fragments as masses or chemical formulas.
The polarity of the Neutral Loss or fragment experiment where the specified neutral loss or
fragment is expected to be found can also be specified.

Analyst Software
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Figure 2-14 IDA Trace Extractor Dialog: Neutral Losses Tab
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Figure 2-15 IDA Trace Extractor Dialog: Fragments Tab
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Click Extract to find the survey XIC traces that give the selected neutral loss or fragment.

6. If the precursor information was saved, then the found precursor mass/time data can be
converted to a compatible format using other scripts.

7. To convert the data, open the Results tab and then select the Results file. View and edit this
file as required.

8. Do one of the following:

* To make a format for the XICfromTable script, click Make XIC Table. The Results file is
converted to a file of the same name with the suffix _XIC.

* To make a format for the CreateQuantMethodFromText script on the Precursor XICs
dialog, click Make Quant Input. The Results file is converted to a file of the same name
with the suffix _Peaks.

9. Click File > Save Settings as.

Tip! Alternatively, previously saved settings can be used. Click File > Load Settings to
open previously saved settings.

Several functions are available in the Tools menu. Users can start processing without
switching to a specific tab.
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RUO-IDV-05-0270-F 31/80



Scripts

IDA Trace Extractor Tabs and Menu Parameters

Parameters

Description

Neutral Losses Tab

Use Masses

Select the required neutral losses as mass.

Use Formulas

Select the required neutral losses as formula.

Start Low mass limit (From mass) for the neutral losses.

End High mass limit (To mass) for the neutral losses.

Formula Chemical formula of the neutral loss.

Extract Start data processing according to the current settings.

Clear Clear all neutral losses in the settings.

Polarity Select the polarity of the neutral loss experiment where the specified

neutral loss is expected to be found.

Fragments Tab

Use Masses

Describe the characteristic fragments in terms of their m/z value.

Use Formulas

Describe the characteristic fragments in terms of their formulas.

Start Low mass limit (From mass) for the fragment m/z window.

End High mass limit (To mass) for the fragment m/z window.

Formula Chemical formula of the fragment (protonated/deprotonated form).

Extract Start data processing using the current settings.

Polarity Select the polarity of the fragment spectrum experiment where the specified
fragment is expected to be found.

Clear Clear all fragments in the settings.

Options Tab

From Time (min)

Start of time region to be processed.

To Time (min)

End of time region to be processed.

Trace Width (Da)

Width of XIC traces in the resulting survey scan and dependent scan

chromatograms and mass tolerance window for processing if the neutral

losses or fragments are specified as chemical formulas.

Remove
Unconfirmed
Peaks

Review all peaks in the survey XIC traces and retain only those that were

validated based on the data in corresponding dependent scan.

Analyst Software
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Parameters

Description

Spectrum Peaks
>

Minimum size of the diagnostic peak in a dependent scan in terms of signal
to noise (lowest measurable signal).

Label Peaks >

The peak label threshold applied to the resulting survey and dependent
scan chromatograms. Only the largest peak in each trace is labeled.

Show Survey
Scan
Chromatograms

Show XICs (original or filtered) from the survey scan that correspond to
parent masses yielding specified fragment or neutral loss.

Show Dependent

Show neutral loss traces (one for each neutral loss) reconstructed from

Chromatograms | dependent scan data.

Subtract Peaks [ Remove peaks that can be found in the control sample XICs from the
Present in survey scan chromatograms.

Control Sample

Results Tab

Result File Select the Results file (identified peak times and masses will be saved to

the selected Results file).

Save Precursor
Information

Write the processing results (the list of found peaks-times and masses) to
the selected Results file.

XIC Peaks >

The minimum size of the peak in the survey scan to be stored in the
Results file.

Append Results
to an Existing File

Do not overwrite the existing Results file.

View Open the selected Results file.

Make XIC Table |Use the selected Results file to prepare the settings file for the XIC from
Table script.

Make Quant Use the selected Results File to prepare an input for

Input CreateQuanMethodFromText script.

File Menu

Load Settings

Open previously saved script settings.

Save Settings As

Save the current script settings for future use.

Set Results File

Select the Results file (identified peak times and masses will be saved to
the selected Results file).

Tools Menu

Scripts User Guide
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Parameters Description
Extract Start data processing using the current settings.
Fragments

Extract Neutral
Losses

Start data processing using the current settings.

Clear Fragments

Clear all fragments in the settings.

Clear Neutral
Losses

Clear all neutral losses in the settings.

Make XIC Table

Use the selected Results file to prepare the settings file for the XIC from
Table script.

Make Quant
Input

Use the selected Results file to prepare an input for the
CreateQuanMethodFromText script.

Table 2-6 Related Scripts

Script Name

Description

Export to JCamp

Converts spectra from wiff format to JCamp format.

MSMS Methods
from MW Lists

Allows lists of molecular weights obtained from text files to be used to
create a series of MS/MS acquisition methods.

Multiple Batch
Scripts Script

Allows multiple batch acquisition scripts to be used at the same time (the
Batch Editor only allows a single batch script to be specified).

Unit Conversion

Converts from one set of concentration units to another.

Wiff To MatLab

Converts the data from a data file from the wiff format to MatLab (mat)
format.

Label Selections

Use this script to add missing labels to the selected peaks in the active graph or to remove

labels.

The script can be run when a pane containing a spectrum or a chromatogram is active in
Explore mode, and there are one or more selections in the active pane. If neither peak mass
(spectrum) nor peak retention time (chromatogram) is available, then the data will be marked
with information for the selection maximum.

Note: Only font type and label color are synchronized with the automatic labels. For the best

performance, synchronize the other font attributes manually in the Appearance Options dialog.

Scripts User Guide
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Note: Labeling spectra with centroid mass/charge state appends just the centroid mass.
Labeling chromatograms with base peak ion mass or base peak ion intensity is not supported.

Use the Script

* Do one of the following:

» To add labels to selections in the active graph, click Script > LabelSelections.

» To view the script description and add the labels to an active Explore pane, press Shift
while clicking Script > LabelSelections.

Label XIC Traces

Use this script when a pane containing one or more XIC traces is active in Explore mode. If
no time region is selected, then the complete chromatogram is considered for processing. The
script labels the largest peak in each XIC trace with mass. XIC traces with a maximum point of
less than 5% of the most intense trace are not labeled. Other types of traces (TIC, ADC) in the
overlay are ignored.

Note: No user settings are required for this script.

Use the Script
* Do one of the following:

» To add labels to a selection in the active graph, click Script > LabelXICs.

» To view the script description and add the labels to an active Explore pane, press Shift
while clicking Script > LabelXICs.

Make Exclusion List from Spectrum

Use this script to create a text file containing all of the peaks from the active spectrum. The text
file is formatted to be directly imported in the software Information Dependent Acquisition (IDA)
exclusion list.

If the spectrum has been previously manually converted to a centroid spectrum, then the
resulting peak list is exported directly to the exclusion text file. Otherwise, the script converts
the spectrum to a centroid spectrum.

Use the Script

1. With a spectrum in an active pane, click Script > Make Exclusion List from Spectrum.
The Make Exclusion List from Spectrum dialog opens.

2. Inthe Exclusion List File Name field, type the name and path of the text file.
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3. Ifrequired, in the Threshold field, type the threshold to be applied to the centroided
spectrum so that small noise peaks are not included in the exclusion list. Type 0 to not
use a threshold.

4. Click Export to export the exclusion list using the specified parameters.

Mascot

Use this script to send either the active spectrum or all product spectra contained in the active
sample, or all samples in the active data file, to the Mascot protein search engine. The script
was co-developed with Matrix Science Limited, the creators of Mascot.

When sending only the active spectrum, the script can work with either MS or MS/MS data.
When sending MS data, the script conducts, a peptide mass fingerprint search is conducted.

When sending all of the spectra, the script works with data acquired using two distinct types of
acquisition methods: either a multiple period/multiple experiment method containing any number
of product experiments or an Information Dependent Acquisition (IDA) method. For multiple
period/multiple experiment data, the script calculates one spectrum for each experiment by
averaging all of the spectra acquired for the experiment. For IDA data, the script uses all of the
dependent product spectra, combining adjacent spectra with the same parent mass and charge
state.

If only one spectrum is being sent to Mascot, then make sure that a centroided spectrum is
active in the Analyst software before running the script. If all of the spectra contained in a sample
are being sent, then the TIC for the sample should be active.

Use the Script

1. With a centroid spectrum in an active pane, click Script > Mascot.

The File, Sample, Periods, and Scan type IDA data fields are read-only and show
information about the active sample.

Figure 2-16 Mascot Search Dialog
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2. In the Search section, do one of the following:
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« If the active pane is a centroid spectrum (either MS or MS/MS), then click The current
spectrum to search this spectrum on its own. Select this option only if the spectrum was
converted to a centroid spectrum using the Centroid command on the Explore menu.

» If the active pane contains MS/MS data, then click All MS-MS spectra for current
sample to perform a single search using all of the spectra for the sample.

+ If the active pane contains MS/MS data and also contains a selected region, then click
All MS-MS spectra from selected region in TIC to perform a single search using only
the spectra from this region. This option can help to speed the generation of the search
input if only a portion of the run is known to contain useful data.

» If the active pane contains MS/MS data and the associated data file contains more than
one sample, then click All MS-MS spectra from all samples for current file to perform
a single search using all MS/MS spectra from all samples in the data file.

3. To open the Mascot search form and populate it with the appropriate information, click
Search. If all product spectra contained in the sample are being searched, then this might
take some time and a progress bar is shown. After the Web form opens, click Start Search.

4. To set the search options, click Options.

Figure 2-17 Mascot Search-Options Dialog
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Tip! To show the Mascot search form defaults Web page, click Set default parameters.

5. To set where the text file used as input to Mascot is located, click Set search file location,
select one of the following options and then click OK.
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Figure 2-18 Search File Location Dialog
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To save the file in the Windows temporary folder with a random but unique file name,
click In the Windows ‘Temp’ folder with a random filename.

+ To always write to a specific file, overwriting the file for every search, click Always to the
following file. To navigate to the folder, click Set.

To create the file with a random but unique filename in the specified directory, click To
the following directory with a random filename. To browse to the folder, click Set.

+ To be prompted to save every time a search is performed, click Prompt me each time
for the location.

In the Default precursor charge states section when searching only the current spectrum,
values here are not available. The precursor charge state should be set manually using
the resulting Mascot web form. When searching product spectra for an IDA run, the charge
state is automatically determined by the script. The values specified here are not used
unless the charge state could not be automatically determined or the Try to determine
charge state from survey scan check box is not selected. When searching product
spectra for a multiple period or multiple experiment LC/MS run, the script always considers
the specified charge states for each product spectrum.

This option is only required for those using an older Mascot software version that does

not accept charge states greater than 5. If one of these older versions is being used, then
make sure that the Discard ions with charge of 5+ or higher check box is selected in the
Default precursor charge states group. Some versions of the Mascot search engine cannot
accept ions with a charge state of 5 or higher and show a warning for each ion exceeding
this limit.

6. To use the default precursor charge states as is, clear the Try to determine charge state
from survey scan check box. Otherwise, the script tries to determine the charge state by
examining the isotope spacing in the survey spectrum, and for Analyst software data, it uses
the charge state determined by the MS Acquisition Engine. The charge state is saved to

Analyst Software Scripts User Guide
38/80 RUO-IDV-05-0270-F



Scripts

10.

the data file. If this check box is selected but the charge state determination fails, then the
default charge states are used.

In the MS/MS averaging of IDA dependents section, edit the parameters that pertain to the
calculation of the product ion spectra for an IDA run.

* The Precursor mass tolerance for grouping field is used to combine adjacent product
spectra in a single spectrum if two spectra have precursors with the same charge state
and the same MW within this tolerance.

* In the Max. number cycles between groups field, spectra are not combined if the
number of cycles between spectra with the same m/z value and charge state is greater
than the specified value. Use this option to keep spectra with significantly different
retention times separate.

* In the Min. num cycles per group field, type the minimum number of spectra that need
to be combined for the result to be kept.

Note: If the dynamic exclusion IDA option was used, then set this value to 1.

In the MS/MS data processing section, select parameters that pertain to the filtering of
product ion spectra.

* Remove peaks if intensity < — Removes peaks that are less than either a specific
count or a specific percent of the maximum peak intensity of the spectrum.

+ Centroid all MS/MS data — To centroid the MS/MS spectra before sending them to
Mascot for searching, select this check box. It is recommended that this centroid option
be enabled.

* De-isotope MS/MS data — If the centroid option is used, then indicate whether isotope
peaks should be removed from the MS/MS spectra before they are sent to Mascot by
selecting this check box. It is recommended that this option be enabled.

* Report peak area (otherwise intensity) — Uses the area of the peak. Otherwise, it
uses the intensity at the apex.

* Reject spectra if less than ‘n’ peaks — Eliminates a spectrum if it contains
unreasonably few peaks after combining adjacent spectra (if used) and centroiding (if
used).

* Remove peaks within ‘n’ Da of precursor m/z — Sets a window around the precursor
ion m/z and then removes any peaks within that window.

In the Other section, select Use original format for query titles if a third-party protein
quantitation application is being used and if the original title format should be used.

To show the Mascot search form defaults Web page, click Set default parameters. Edit the
defaults so that they do not need to be manually reset every time a search is submitted.
After changing the parameters, click Save defaults as cookie to close the Web page.
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Mass Defect Filter

The identification of drug metabolites in biological fluids with low concentrations from a total
ion chromatogram (TIC) is challenging because of significant interferences from endogenous
species. A technique of filtering the data based on the mass defect of the parent drug and

a small tolerance value has been used to decrease the amount of interference. Using this
technique helps in the identification of phase | and phase |l metabolites.

The Mass Defect Filter script filters either a TIC or a spectrum using this technique. Only those
data points in the spectrum whose centroid mass is within the tolerance range of the mass
defect of the precursor ion applied at that nominal mass are kept. All other points are excluded.
Summing the intensity for each spectrum generates the TIC. A further filtering based on absolute
mass can also be applied.

A new graph of the filtered TIC or spectrum is shown below the current graph.

Use the Script

1. With either a spectrum or a TIC active, click Script > Mass Defect Filter.
The Mass Defect Filter Settings dialog opens.

2. In the Parent Formula field, type the formula for the parent ion. The Nominal Mass and
Mass Defect fields are automatically updated.

3. If the parent formula is unknown, then type values in the Nominal Mass and Mass Defect
fields.

4. Inthe Mass Defect Tolerance (+/-) field, type the tolerance value.

If required, type a value in the Resolution Factor field. The Resolution Factor further
filters the data by keeping only the centroid values whose resolution is greater than or equal
to it.

6. If required, to allow the mass defect to be applied differently at each nominal mass in the
spectrum, click the Use Dynamic Mass Defect Calculation check box.
If the check box is cleared, then a constant value of the mass defect is added to each
nominal mass.

7. In the Mass Range Parameters section, select the Use Mass Range Filter check box to set
the mass range parameters.
Only masses in the spectrum between Start Mass and Stop Mass inclusively are retained.

8. To start processing, click OK.

Merge MRM

Use this script to add all of the experiment data from the method to be merged to the base
method. Both methods should have only one period and one experiment. The script does not
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limit the number of mass ranges in an experiment. All mass ranges are saved to the base
method.

This script can be used to merge multiple final methods created by cCompound optimization.
After the methods are merged, the LC information can be modified, if necessary, to reflect the
analysis conditions.

Use the Script
1. Click Script > Merge MRM.

Figure 2-19 Merging MRM methods Dialog
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2. To browse to the original acquisition method file or template, click the button to the right of
Original method.

3. To specify the name and location of the merged acquisition method file, click the button to
the right of New Method, type the name of the method, and then click Open.

4. To add an acquisition method to the list of methods to be merged, click Add to the right of
Methods to be merged. To remove a method from the list, click Remove.

5. (Optional) If both methods were created using Compound Optimization, then select the
Update MRM compound ID from the file name check box to populate the compound ID
column with the compound name in the merged method.

6. To add all the mass ranges from the selected methods, click Go.

MRM3 Optimization Script

Use this script for quantitation analysis on QTRAP systems to provide increased specificity
and, therefore, improved detection when quantifying analytes in complex matrices. This script is
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designed to generate an optimal MS3 acquisition method by infusion. The script performs the
following optimization steps:

» Confirm precursor mass

» Optimize transmission to collision cell

* Determine the major fragment ions

* Optimize the Collision Energy (CE) for each fragment ions
* Perform MS3 scans on each fragment ion

+ Optimize Excitation Energy (AF2) for all MS3 scans

* Generate a report

+ Save all data and acquisition methods

The script can also be used in qualitative applications to generate collections of MS/MS and
MS3 spectra for compounds in a semi-automated way (that is, one compound at a time).

MRM3 Optimization Window Overview

Use the controls in the MRM3 Optimization window to navigate. The window also shows the
optimization results as they are generated. The following is an overview of the various sections
in this window.

Table 2-7 MRM3 Optimization Window

Field Description

Status Window [When the script is first started, this window shows the current optimization
settings that will be used for optimization. When the optimization is started,
spectral information is shown in this window.

Log File Shows the results found during optimization in text format. Each entry found
in this section is also added to the generated Log.txt file.

Overall Shows the overall optimization progress.

Progress

Main Controls Contains all of the main functions associated with the setting and execution
of the optimization process.

* Click View Results, to open and review the file using Microsoft Notepad. After the
optimization is completed, a Results.txt file is automatically generated and saved.

» Click Settings to open a window to type compound information required for the optimization
process.

» Click Start to initiate the optimization process. During optimization, this button is renamed to
Abort, which can be clicked to stop the optimization process.
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Figure 2-20 MRM3 Optimization Window

= MRM3 Optimization X

Cuirent Setlings: Enhan::a!d R egolution
Analyst Project I5B Kinaze [ Datamnine achual 15t precurson
Method 01.dam @ )
Compound Mame  Pephide 071 Multiple lon
11 Resolution LIt [J0ptimize DP
Expected mfz 5810392 Da [ Oplimize EP
Polanty Positive: B
Advanced Seffings: @ (4
ER Scan Rate 1000 Dals
Q1M1 DP Hdl‘l‘p A0 ko 1508 with 5 slep Enhanced Product lon
EFi ScanRale 1000 Dads [ Get 2nd precursors
EF1 # Znd Piec B o - o
ME3 Scan FBate 1000 Dads M l.‘ll:l.h. Reaction Monitoring
Final Methods Sawe all final methods [ Optimize CEs for 2nd precursors
MS/MS/MS
. _ [ Optimize AF25 for 2nd precursors
" Select [Setings] buttan to madily the curert setlings and gat 3rd precursors [0 of 0)
* Select [Advancad] button in Settings 1o modify the advanced setings @
Generate Final Methods
[ Genesate final MS/MSMS
aoquisibon methods
stat | B |

Item Description
1 Status pane
2 Log file
3 Main controls
4 Overall progress

Set the Preferences
The Settings dialog opens automatically every time the script is launched.

1. Click Browse to browse to the starter acquisition method. This method contains the source
conditions to be used for the optimization.

2. Inthe Compound Name field, type a descriptive compound name. This name is used as a
prefix to all of the acquisition methods and data files generated.

3. Inthe Expected m/z (amu) field, type the expected mass-to-charge ratio (m/z) for the
compound. If the m/zvalues of the compound is not known, then click Calculate from
chemical formula to calculate it from the chemical formula of the compound. Refer to the
section: Calculate m/z.

4. In the Q1 Resolution field, select a Q1 Resolution to be used for MS/MS and MS3.
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5. In the Polarity group, click a polarity, which can differ from the starter method. The Do both
option is currently not supported.
6. To modify some of the settings used by the optimization process, click Advanced. Refer to
the section: Use the Advanced Settings Dialog.
7. To verify and use the updated settings, click OK.
Use the Script
1. Build a starter acquisition method if one does not already exist. The starter method should
be a Q1 acquisition method created in Manual Tune and should contain the source
conditions required for the tuning process because these are not optimized by the script.
2. Save the method in the Acquisition Methods folder of the required project where all
generated files will be saved.
3. Click Script > MRM3 Optimization.
Figure 2-21 Settings Dialog
[59. Settings ﬁ
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4. Enter the compound information required for the optimization process and then click OK on
the Settings dialog.
5. To initiate the optimization process, click Start in the MRM3 Optimization window.

Calculate m/z

The m/z calculator is accessed through the Settings dialog.

1.

In the MRM3 Optimization window, click Settings.
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The Settings dialog opens.

2. Click Calculate from chemical formula.

Figure 2-22 Calculate m/z Dialog
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3. In the Chemical Formula field, type the chemical formula of the compound. Use capital
letters for elements. The chemical formula for peptides is also entered in this dialog.

4. In the Num of charges field, click the number of charges.
To calculate the m/z for the entered chemical formula and charge, click Calculate.

6. To close the calculator and update the Expected m/z (amu) field in the Settings dialog with
the calculated m/z, click Use m/z.

Use the Advanced Settings Dialog

In this dialog, a description for each of the optimization steps is provided. Some of the settings
can be modified to customize the optimization.

1. In the MRM3 Optimization window, click Settings.
The Settings dialog opens.

2. Click Advanced.
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Figure 2-23 Advanced Settings Dialog
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In the Scan Rate fields in the Enhanced Resolution, Enhanced Product lon and MS/MS/MS
groups, select a scan rate for ER, EPI, and MS3.

In the Q1 Multiple lon group, in the DP Ramp fields, type the declustering potential (DP)
range for optimization. The range is expressed in absolute values and the appropriate
polarity is automatically applied based on the selection made in the Settings dialog.

In the Enhanced Product lon group, do the following:

* In the 2nd Precursors field, type the maximum number of second precursors (fragment
ions) used for MS3 optimization. Type a number between 1 and 10.

* In the Mass range field, type a mass range for the second precursors that will be

selected for MS3 optimization.

* In the CE field, type a collision energy value and in the CES field, type a collision energy
spread value that will provide a good MS/MS spectrum from which fragment ions can be

selected.

To generate all of the final MS3 methods for each second precursor and the optimal MS3
method for quantitation analysis, in the Generate Final Methods group, click Save All
Final Methods. Click Save Optimal Method Only to save only the optimal MS3 method

(most sensitive for quantitation).
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7. Click OK to accept the updated Advanced Settings.

Optimization in Progress

When the optimization is started, Manual Tune in the Analyst software is automatically stopped.
While the script is running, all of the functions in the software can still be used. A Log.txt file

is also updated as each part of the optimization procedure is completed. To stop the script at
any time, click Abort. Refer to the following figures for examples of the script. In the Overall
Progress section, the Checklist images and text fonts represent different statuses that are
described in the following section.

Figure 2-24 Status Examples

[(Drask not performed yet — text is black
(2)Task in progress — text is blue and italic
[¥il(3) —text is grey
E‘@Task completed (hyperlink) — text is blue and underlined
\ask completed (no link) — text is blue
@Dan‘ of task completed (hyperlink) — text is blue, underlined, and italic

Item Description

1 Tasks not performed yet - text is black

Task in progress - text is blue and italic

Task will not be performed - text is blue and underlined

Task completed (hyperlink) - text is blue and underlined

Task completed (no link) - text is blue

|||l DN

Part of task completed (hyperlink) - text is blue, underlined, and italic

When the text is underlined, click it like a web page hyperlink and the corresponding spectrum
or chromatogram is shown. The text found under MS/MS/MS also shows the MS3 scan number
that is being performed because it is possible to have between 1 and 10 scans. The Overall
Progress section also includes a Message area. In this area, a progress bar shows the current
step progress. Above the progress bar, various messages are shown such as the time and other
statuses for the current optimization step.
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Figure 2-25 MRM3 Optimization Window After an EPI Scan
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Item Description
1 Checklist
2 Message

In the spectral status window, the previously generated spectrum or chromatogram is shown.
When one of the checklist items is selected, the corresponding graph is shown. The scan type
name indicates which scan is currently being shown. For each completed step, it is possible
to open the acquisition method (dam) or data file (wiff) associated with the graph shown. If an
MS/MS/MS scan is shown, then use the buttons to cycle through the different MS3 scans.
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Figure 2-26 MRM3 Optimization Window During an MS3 Scan
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Item Description
1 Scan type
2 Buttons to cycle through different MS3 scans
3 Links

Optimization Complete

When the quantitative optimization for MS3 is completed or stopped, a Results.txt file is
generated. This file is automatically opened in Microsoft Notepad. Click View Results from
the MRM3 Optimization window to view the file. The various parts of the Results.txt file are
described below.

+ Time and Duration: Shows the date and time duration of optimization.
+ User Starting Conditions: Shows the settings and Advanced Settings in this section.

* Optimization Conditions Found: Shows the optimal conditions found during the ER and
Q1MI scans.

* MS3 Fragments Found and Associated Losses: Shows the fragments and optimal
conditions (collision energy and excitation energy) as well as associated losses found for
the EPI scan and MS3.
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Figure 2-27 Optimization Report
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Item Description
1 Time and duration
2 User starting conditions
3 Optimization conditions found
4 MS3 fragments found and associated losses
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All of the generated acquisition methods have a descriptive file name in the format [supplied
compound name] + [scan type] + [m/z] + dam. These methods are saved in the same folder as
the starter acquisition method.

All of the data, Log.txt, and Results.txt files are saved in a Data subfolder that is created in
the same project as the starter acquisition method. The subfolder has the format [supplied
compound name] + OptMS3 + ([date], [time]). The data files have the format [supplied
compound name] + [scan type] + [m/z] + wiff.

Detailed Description of Script Logic: Initialization

This section describes each phase of the optimization process. All scans are performed with the
number of scans to sum set to 3.

Before performing any optimization scans, the MRM3 Optimization script performs the following
initialization steps. If an error occurs during any of these steps, the script stops the optimization
process.

1. Make sure that the Analyst software is running.
2. Load the starter acquisition method to determine if it is valid and to check the device type.
3. Create a new Data subfolder to store the wiff files.

4. Create the Log.txt file.

Enhanced Resolution Scan

This step confirms the mass of the ion used for optimization. The ER scan is performed for 20
cycles at the specified scan rate. The most intense peak within £ 1 amu of the expected first
precursor m/z value is then selected. As in the Analyst software, this scan is performed with a
30 amu mass range around the specified m/z value. For multiply charged species, the C12 ion is
determined in this step.

Q1 Multiple lon Scan

This step optimizes transmission of the ion of interest up to the collision cell. This is performed
using a Q1 Ml scan. The script first optimizes the DP parameter by performing the scan at the
specified DP ramp. Optimize the EP parameter by ramping it from1Vto 12V (-12Vto-1V
for negative mode), with 0.5 V step. If the optimal EP is less than 10 V (greater than —10 V for
negative mode), then DP is re-optimized. The CEP parameter is also optimized by ramping from
0Vto100V (100 V to 0 V for negative mode) with 2 V step. In determining the optimal voltage,
graphs are smoothed two times and the voltage yielding the greatest ion count is used. Dwell
Time for each scan is set to 100 ms.

Enhanced Product lon Scan

This step selects the fragment ions that will be used for MS3 optimization. This is performed
using an EPI scan for three cycles at the selected scan rate. Specify an optimal CE for
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the compound to be analyzed. If the optimal CE is unknown, then specify a CES value so

that a range of CE settings are used. The most intense second precursor peaks are then
found, excluding any peaks within = 2.5 amu window of first precursor. The number of second
precursors to use is selected in the Advanced Settings. The mass range from which the second
precursors are selected is specified by the user.

Multiple Reaction Monitoring Scan

This step optimizes the collision energy for each of the fragment ions selected from the EPI
scan. This is performed using MRM scans. Use CE ramps of 5t0 130 V (-130to -5 V in
negative mode) with 2 V step and Dwell Time of 50 ms. Each overlaid graph is then smoothed
two times and the voltages yielding the greatest ion count are used as the optimal CE values.

MS/MS/MS (MS3) Scan

The script performs an MS/MS/MS (MS3) scan for each chosen second precursor at the
specified scan rate and with an AF2 ramp of 0 to 100 V with 2 mV step for both polarities.

The fill time of the scan is set, and QOtrapping can be turned on for maximum sensitivity if
required. The lower limit of the mass range for the MS/MS/MS (MS3) scan can be specified, and
the upper limit is second precursor + 5 amu.

The generated graphs are smoothed twice and the optimal AF2, as shown in the following figure,
is obtained when the residual intensity of the second precursor (based on XIC) is at 5% of its
maximum intensity. The spectrum at this AF2 value is then used to find the two most intense
second-generation fragment ions, excluding peaks within £ 1 amu of the second precursor. If the
second precursor m/z value is greater than 10% of the total ion count, then no fragments from
that spectrum is used. This condition exists because if the second precursor m/z value is greater
than 10%, then there is insufficient fragmentation.

Analyst Software Scripts User Guide
52/80 RUO-IDV-05-0270-F



Scripts

Figure 2-28 How AF2 is Determined
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Generate Final Methods

After the optimization scans are performed, the script generates the final MS/MS/MS methods. If
the Save Optimal Method Only option is clicked in the Advanced Settings dialog, then only an
optimal MS/MS/MS method with + 10 amu around the most intense second generation fragment
ion is created. If the Save All Final Methods option is clicked, then the optimal method as well
as an MS/MS/MS method for each of the top second precursors are created using a mass range
from the user-defined lower limit to an upper limit of (second precursor + 5) amu.

MS3 Quant Optimization Script

The MS3 Quant Optimization script has been replaced by the MRM3 Optimization script. Users
who have upgraded from earlier versions of the Analyst software might still have this script
installed. The MS3 Quant Optimization has not been tested with the Analyst software, version
1.6.3 or later. Use the MRM3 Optimization script instead.

MSServiceLog Script

By default, readbacks from a mass spectrometer are recorded in the MS Service log file.

Use the MSServicelLog script to turn off the recording of the readbacks or to start recording
the readbacks from the instrument in the MS Service log file. The MSServicelLog script is

only applicable to the SCIEX 3500,SCIEX 4500 systems, SCIEX 5500 systems, SCIEX 5500+
systems, SCIEX 6500 systems, and SCIEX 6500+ systems.
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The MSServicelog script can be used without an active hardware profile but any changes made
to the MS Service log settings take effect only after the hardware profile is reactivated.

Use the Script

1. Deactivate the hardware profile.
2. Click Script > MSServicelLog.

Figure 2-29 MS Service Log Settings Dialog
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Logaing

@ Log Interval (min) 15.00

@ Log File Size (MB)  10.00

Dizable @

MS5cr. csv

C:'\ProgramDatalaB SCIEX AnalystiMss

@

[ Use Defaults ]

Name

Description

Enable

Select to start recording the readbacks from the mass
spectrometer to the MS Service log file using the
MSServicelLog script.

Disable

Select to turn off the recording of the readbacks from
the mass spectrometer to the MS Service log file
using the MSServiceLog script.

Log Interval
(min)

Specify how frequently, in minutes, the readbacks
from the mass spectrometer will be recorded to
the MS Service log file. The default value is 15
minutes and the allowed range is from 1 minute to
1440 minutes.
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Item Name

Description

4 Log File Size
(MB)

Specify the size of the log file. The default size is
10 MB, and the allowed range is 1 MB to 1000 MB.
There can be up to two log files:

» The current log file, where the readbacks from the
instrument are recorded.

* The archived log file.

When the current log file reaches the specified size, it
is archived with an predefined archive filename, and
a current log file is created to record the readbacks
with the log file name specified in the MS Service Log
Settings dialog.

5 Log Filename

Specify a name for the log file. The accepted file
extensions are csy, txt, or log.

6 Log File Path

Specify the location where the log file is stored.
Make sure that the new location is created

inside the default location C: \ProgramData\AB
SCIEX\Analyst\MSServiceLog.

7 Use Defaults

Click to revert to the preset values in all the fields in
the dialog.

Click Disable to turn off the recording of the readbacks in the MS Service log file.

Click Enable to start recording the readbacks from the mass spectrometer to the MS

Service log file.

5. To change the values in other fields in the MS Service Log Settings dialog, refer to the

figure: Figure 2-29.
6. Click OK the apply the changes.

Multiple Batch Scripts

Use this script to attach multiple acquisition scripts to a single batch that is submitted to

the queue. These acquisition scripts are used to immediately process the data either after a
sample completes or after the batch completes. In the Analyst software, only one script can be
submitted with a batch, but sometimes it is convenient to run two or more scripts to perform two

or more different types of processing.

Use the Scripts

1.  When creating a batch, in the Batch Script field, browse to the script.

Scripts User Guide
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5.

After the batch is submitted to the queue, the following dialog opens in which the additional
acquisition scripts can be attached.

Figure 2-30 Multiple Batch Scripts Script Dialog
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To attach an additional script to this batch, click Add Script to browse to the acquisition
script.

To remove a script, click the script and then click Remove Selected.

Clear the Only show this dialog again if the control key is down check box to show this
dialog when submitting the batch.

Click Run to attach all of the acquisition scripts to the batch.

Open in Workspace

Use
prev

this script to open a sample in a previously created workspace. This script loads the
ious workspace and shows the sample in the same layout as specified in the saved

workspace. It is not possible to create a workspace that specifies pane arrangements so that
any sample can be opened in the workspace with the same pane arrangements. For more

infor

mation on workspaces, refer to the online Help.

Use the Script

1.

Click Script > OpeninWorkspace.

The Open in Workspace dialog is shown with the current working project data folder loaded

in the Data files list.
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6.

Figure 2-31 Open in Workspace Dialog
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To select a data file from another project, click File > Open Data File.

In the Data files list, click a data file.
All of the samples in the selected data file are shown in the Available samples list.

After choosing the sample, select a workspace in the Available workspaces list.

Tip! To select a different workspace, click Workspace > Open Workspace.

To set a default workspace to be used every time this script is run, select the Set Selected
Workspace As Default check box.

To open the sample, click Open Sample in Workspace.

Known Issues and Limitations

The Open in Workspace script is for the presentation of graphs only. The script cannot handle
data lists that are saved in the workspace. If the workspace contains data lists, then a Type
Mismatch error is shown. If this error occurs, save the workspaces with the graphs only and
then, after loading the workspace, create the necessary data lists.
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Peak List from Selection

Use this script to determine the peak data for a selected region or regions in the chromatogram.
The % area and % height listed relate to peaks in the selection. The peaks are listed in a text
pane below the active chromatogram. The peak definition is shown in the chromatogram. For
more information, refer to the figure: Figure 2-32.

Use the Script

1. To process the data, make one or more selections in the chromatogram and then select the
script from the menu.

2. Do one of the following:
* To run the script, click Script > PeakListFromSelection.

» To view the script description, and get the peak list, press Shift while clicking the script.

Figure 2-32 Data Processing with the PeakListFromSelection Script
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Regression Calculator

Use this script to calculate the slope, y intercept, and r values for each mass/speed dependent
parameter.
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Use the Script

1. Click Script > Regression Calculator.

Figure 2-33 Regression Calculator Dialog
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2. Type data in pairs of X and Y co-ordinates.

3. After entering two or more pairs, to get the Slope, Intercept, and R? value, click Calc.
4. To delete the values for X and Y co-ordinates, click Clear.
5

To exit the application, click OK.

Remove Graph Selections

Use this script to clear a selected area in the graph. For example, the graph selection line can be
cleared from the graph.

Use the Script

» To remove selections from the graph, click Script > RemoveGraphSelections.

Repeat IDA Method

Use this script on an acquisition computer. It opens the acquisition method for the data file and
updates the exclusion list with the masses and times that have been acquired. The method is
saved under the same name.
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Use the Script

1. In Explore mode, open an IDA data file.
2. Click Script > RepeatIDAMethod.

3. To keep the previous exclusion list, press the Ctrl key while clicking the script.

Savitzky-Golay Smooth

In the Analyst software, a graph can be smoothed in Explore mode using one of the smoothing
algorithms from the Explore menu: Moving Average Smooth (shown as Smooth under Explore
menu) or a Gaussian Smooth.

Alternatively, if the Savitzky-Golay Smooth script is installed, then a graph in Explore mode
can be smoothed using the Savitzky-Golay Smooth algorithm from the Script menu. The active
graph in the Analyst software is replaced by the smoothed graph.

If the IntelliQuan integration algorithm is used in Quantitate mode, then the Savitzky-Golay
smooth algorithm is used. The Savitzky-Golay Smooth script smooths a graph in Explore mode
in the same way as when data is smoothed in Quantitate mode using IntelliQuan integration
algorithm.

Use the Script

1. With the peaks of interest selected in the active spectrum, click Script > Savitzky-Golay
Smooth.

Figure 2-34 Savitzky-Golay Smooth Dialog
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2. In the Smoothing Half Width field, to set the half-width for smoothing the data. The total
width is twice this value plus one.

This parameter is the same as the smoothing parameter used with the IntelliQuan algorithm
in the Analyst software.

3. To perform the smoothing, click OK.
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Selection Average and Standard Deviation

Use this script to calculate the average intensity and standard deviation of a selection in a graph
for both spectral and chromatographic data. The graph is labeled with both the average and
standard deviation of the selection.

Use the Script

» Select either an active spectrum or an active chromatogram and then click Script >
Selection Average and StdDev script.
The graph is labeled with the average and standard deviation of the selection.

Known Issues and Limitations

This script works only once for each graph. Use the following procedure to run the script on the
same graph more than once.

1. Copy the graph to a new pane and then click Explore > Duplicate Data > Same Window.

2. Make a selection in the new graph pane and then run the Selection Average and StdDev
script again.

Send to ACD SpecManager

This script is similar to the Export to JCamp script. However, instead of prompting for the name
of the JCamp file, the script exports the spectra to a temporary file and then sends them directly
to the ACD SpecManager application. There is no need to open this temporary file directly.

Use the Script

The first time the script is run, the software prompts the user to locate SpecManager. The user is
not prompted again unless Ctrl is pressed while the script is clicked.

Note: This script cannot be used with batch acquisition.

Prerequisites

* The SpecManager software must be installed.

1.  With either a chromatogram or a spectrum in an active pane, click Script > Send to ACD
SpecManager.

The JCamp Options dialog opens. If the user is interactively processing a single spectrum
active in the Analyst software, then these options do not apply.
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Figure 2-35 JCamp Options Dialog
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2. To centroid the exported spectra, select the Centroid Exported Spectra check box.
This option reduces the size of the exported JCamp file.

3. To select the threshold to be applied to the exported spectra, in the Threshold field, type a
value. To not use a threshold, type 0 in the Intensity Threshold field.

4. Select the Only show this dialog again if the control key is down check box to have the
JCAMP Options dialog open if Ctrl is pressed when the script is selected from the Script
menu or when the batch is submitted to the queue.

5. Click OK to continue processing and to export the spectra.

These values are used as defaults until they are changed.

Note: To close the dialog without making any changes, click Cancel. In the case of
interactive use, canceling the dialog also stops the export operation. However, in the case
of batch operation, the batch is still acquired and JCamp files is exported using the original
parameters.

Signal-to-Noise Using Peak-to-Peak

The Analyst software calculates the signal-to-noise ratio by taking the standard deviation of all
of the chromatographic data points between the specified background start and background end
times.

Use this script to calculate the signal-to-noise ratio for the active chromatogram. The script
subtracts the average background signal from the selected peak and then divides the subtracted
signal by the peak-to-peak noise level. It then differentiates the noise and peak regions based on
the maximum intensities of each region. Upon completion, the active chromatogram is labeled
with the signal-to-noise ratio.

Use the Script

» With a noise region and the peak of interest selected in the active chromatogram, click Script
> S-to-N.
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The signal-to-noise ratio is calculated and the graph is labeled.

Tip! To remove the labels, press Ctrl while clicking the script.

Related Scripts

S_NstdDevQS: Calculates the signal-to-noise value with a method that uses the standard
deviation of the noise regions.

Signal-to-Noise Using Standard Deviation

Use this script to calculate the signal-to-noise ratio of chromatographic peaks and label

them. The script requires two regions to be selected on the chromatogram: a selection/region
containing the noise region and a selection/region containing the peak of interest. The script
determines which region contains the peak and the noise based on maximum intensities in each
selection. It subtracts the average background signal intensity from the peak signal intensity and
then divides the subtracted signal by a user-specified factor multiplied by the standard deviation
of the noise region.

Use the Script

1. With a noise region and the peak of interest selected in the active chromatogram, click
Script > S_NstdDevQS.
The S/NxstdDev dialog opens.

Figure 2-36 S/NxstdDev Dialog
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2. To erase any labels current on the active chromatogram, click Erase Labels.

3. To calculate the signal-to-noise ratio and label the graph, click Go.

Related Scripts

Signal-to-Noise Using Peak-to-Peak: Calculates the signal-to-noise for an active
chromatogram. The background subtracted signal is divided by the peak-to-peak noise level.
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sMRM Calculator

Use the sMRM Calculator script for a visual representation of a Scheduled MRM (sMRM)
algorithm acquisition method. The script uses four graphs to show an overview of the MRM
transition, its concurrency, its projected cycle time, and the dwell time to be applied to it. Refer
to the figure: Figure 2-38. To achieve a suitable arrangement of the transitions over the run time,
change the parameter values, such as Maximum Dwell, Minimum Dwell, Target sMRM Cycle
Time or Target sMRM Scan Time, Window Width, MRM Pause Time, and Settling Time, in
the script dialog. The four graphs are updated accordingly. Repeat this process until the required
arrangement of the transitions is achieved.

Note: If Target Cycle Time is selected in the original method, then it cannot be changed to
Target Scan Time in the script dialog. If Target Scan Time is selected in the original method,
then it cannot be changed to Target Cycle Time in the script dialog.

Note: The Settling time option can only be modified for SCIEX 5500+ systems and
SCIEX 6500+ systems in the sMRM Calculator script dialog.

Use the Script

Prerequisites

» Make sure that the Analyst software is open and a hardware profile is activated.

* Make sure that a Scheduled MRM (sMRM) algorithm acquisition method is already created.

1. Click Script > sMRM Calculator.
The sMRM Calculator dialog opens.
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Figure 2-37 sMRM Calculator Dialog
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Click Load Method to select an existing Scheduled MRM (sMRM) algorithm acquisition
method.
The Open dialog opens.

Note: Only an acquisition method that contains Scheduled MRM (sMRM) algorithm
experiments and for the active mass spectrometer in the currently selected project can

be opened in the sMRM Calculator script. Only the details for Scheduled MRM (sMRM)
algorithm experiments are shown. The non-Scheduled MRM (sMRM) algorithm experiments
are labeled as not Scheduled MRM (sMRM) in the script.

Select the Scheduled MRM (sMRM) algorithm acquisition method and then click Open.

The selected acquisition method opens in the sMRM Calculator dialog. The file path of the
open acquisition method file is shown in the title of the dialog.
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Figure 2-38 Acquisition Method Opened in the sMRM Calculator Dialog
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Item Description

1 The left pane contains instrument and Scheduled MRM (sMRM)
algorithm parameters. The parameters shown in this pane change
depending on the acquisition method opened.

If the arrangement of the transitions is not suitable in the four graphs in
the right pane, then change the editable parameters and settings in the
left pane. The affected columns in the table and the graphs are updated
accordingly. The parameter values can be modified within the allowable
range until a suitable arrangement of transitions is achieved.

For example, if the value in the Target sMRM Scan Time field is
changed, then the dwell time is recalculated and updated in the table,
and the graphs are also updated accordingly.

For example, if the value in the Windows Width field is changed, then
this value is updated in the Window column for all of the transitions

that use this global setting. The dwell time for all of the transitions is
recalculated and updated in the table. The graphs in the right pane

are also updated accordingly. For transitions with their own detection
window settings in a Scheduled MRM (sMRM) Pro algorithm acquisition
method, updating the global setting Window Width in the left pane does
not update the values in the Window column for these transitions in the
table.

Note: The fields that show as grey in the left pane are not editable and
the value cannot be changed.
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Item

Description

The index, compound ID, Q1 and Q3 masses, polarity, window width,
retention time, and dwell time are shown in the middle pane. The default
view is in order by index number.

To rearrange the view based on the information in the other columns,
click the title of one of the seven columns: index, ID, Masses, +/-,
RT, Window, and Dwell. The middle pane refreshes, showing the
information sorted in the alphanumerical or numerical order of the
selected column.

For methods for SCIEX 3500 systems, SCIEX 4500 systems, SCIEX
5500 systems, SCIEX 5500+ systems, SCIEX 6500 systems, and
SCIEX 6500+ systems, the window width for all transitions in that
Scheduled MRM (sMRM) algorithm experiment can also be edited in
the table. The dwell time in the table and the graphs in the right

pane are updated accordingly. Editing the window width in the table
converts a Scheduled MRM (sMRM) algorithm acquisition method to a
Scheduled MRM (sMRM) Pro algorithm acquisition method.

Note: The window width that uses the global setting from the left pane
has a yellow background. After the window width in the table is manually
modified for an individual transition or if it already uses the advanced
window width that is specific for its transition, then the background color
for that cell changes to white.

The right pane shows all of the Scheduled MRM (sMRM) algorithm
transitions contained in the loaded Scheduled MRM (sMRM) algorithm
acquisition method graphically as four different types of graphs.

* The selected MRM transition in the table is depicted by the green
vertical line in the graphs.

* The light grey areas in the graphs represent the retention time zones
where there is polarity switch in each cycle.

» Tool tips in each graph show X- and Y-values for the transition under
the cursor. For the Method Overview and Dwell Time graphs, the
compound ID is also shown in the tool tips.

» Clicking an MRM transition in the Method Overview graph selects
that transition in the other three graphs and the table.

The first graph, Method Overview, shows all of the transitions and the
detection window of each transition. The X-axis shows the retention
time. The Y-axis shows the MRM index number, which is the order in
which the transitions were entered in the method.
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8.

Item Description
5 The second graph, MRM Concurrency, shows the retention time on the
X-axis and the MRM transition concurrency at each retention time on
the Y-axis.
6 The third graph, Projected sMRM Cycle Time, plots the projected cycle

time over retention time. The red line represents the Target Cycle
Time, if it is used. If the Target Scan Time is used, then the value
of the red line is the sum of the Target sMRM Scan time of all of the
Scheduled MRM (sMRM) algorithm experiments in the method.

Note: More data points are expected for transitions for which the
Projected sMRM Cycle Time is much lower than the Target Cycle
Time or the sum of the Target Scan Time (where the red bar is). Fewer
data points are expected for transitions for which the Projected sMRM
Cycle Time is much higher than the Target Cycle Time or the sum of
the Target Scan Time (where the red bar is).

7 The fourth graph shows the dwell time for each transition at its retention
time. The X-axis shows the retention time. The Y-axis shows the dwell

time to be applied.

Change the parameter values as required to optimize the method to achieve a better
distribution of the Projected sMRM Cycle Time.

Click Save Method.
The Save Method File window opens.

The changes to the method can be saved in the original acquisition method or can be saved
as a new acquisition method. If the changes are saved to the original acquisition method,
then the original parameter values are overwritten by the new values.

Type a new file name or select the original method and then click Save.

Open the saved acquisition method in the Acquisition Method Editor to view the new
changes.

If the original method was open in the Acquisition Method Editor, then the method must
be closed and opened again.

Click the X in the upper-right corner of the sMRM Calculator dialog to close the dialog.

Split Graph Script

Use this script to split a spectrum or chromatogram in to a specified number of panes. Each
resulting pane shows a proportional fraction of the total mass (or time) range. For example, if a
spectrum showing a mass range of 100 Da to 400 Da is split in three, then the original spectrum
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shows a range of 100 Da to 200 Da, the second (new) spectrum shows 200 Da to 300 Da,
and the third (new) spectrum shows 300 Da to 400 Da. The intention is to allow the maximum
possible number of peaks to be labeled for subsequent printing.

Use the Script

1. With either a chromatogram or a spectrum in an active pane, click Script > SplitGraph.

Tip! Press Ctrl while opening the script to specify the number of panes to create.

Note: Make sure that the mass (or time) range for splitting is shown. If necessary, dock the
graph to make sure that the whole graph can be seen.

2. Do one of the following:

» The current version of the XICfromTable script can process a maximum of 25 XIC mass
ranges. If Ctrl is pressed while the script is clicked, a dialog opens prompting the user to
select the number of panes to create. The preset value is four.

« If the Ctrl key is not pressed, then the last number typed in the dialog is used.

Subtract Control Data from Sample Data

Use this script when the sample data of interest are in the active graph. The data can be any
spectrum, TIC, or ADC trace. The script determines the data type, retrieves the corresponding
data from the control file, and then shows the subtracted data in a graph.

Select to overlay the subtracted data with sample data or control data.

Use the Script

1. To process the data with current preferences, click Script > SubtractControlData.

2. If the script is being run for the first time then do one of the following:

» To view the script description, set the processing preferences, and then obtain the
subtracted data, press Shift while clicking the script.

» To update the processing preferences and then obtain the subtracted data, press Ctrl
while clicking the script.

Analyst Software Scripts User Guide
70/80 RUO-IDV-05-0270-F



Scripts

Figure 2-39 Subtract Control Data Preferences Dialog
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Unit Conversion

Use this processing script to convert from one set of concentration units to another.

Use the Script

1.

Click Script > Unit Conversion.

Figure 2-40 Unit Conversion Dialog
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2. Inthe Convert from field, type the concentration and units to be converted.

3. If the conversion is from a weight-based concentration (for example, g/L) to a molar-based
concentration (for example, mol/L), then in the MW field, type the molecular weight of the
component.

4. In the to field, type the unit.

To perform the conversion, click Convert.
The calculated values are shown in the to field.

6. To retrieve these values, press Ctrl +C to select and copy them to the clipboard. These
values can then be pasted in another application.
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Wiff to MatLab

Use this script to extract the data from a wiff file and create the following matrices in a MatLab
file: Data, Masses, Wavelengths, Scans, and Filename. For more information about these
matrices, refer to the table: Table 2-8. This MatLab file can then be included in a MatLab script
and used to compute and show the results.

Although the Analyst software can be used to perform various data manipulations, use this
specialized script, Wiff to MatLab, for data computations. The Analyst software cannot extract
data from a wiff file and then store it in a file that can be read and interpreted by MatLab.

In addition to exporting the mass spectral data, this script can also export data from a diode
array detector (DAD).

The script will create a single MatLab mat file for each sample to be translated. Depending on
the type of mass spectra data and the user options, the script can create data in two different
formats:

» The first format saves the intensities in a matrix of size (hnumber of masses) x (number of
scans). There is therefore an entry in the matrix for every mass that was scanned and every
spectrum. This is the default format for quadrupole spectra and the format that is always used
for diode array data.

* The second format is sparse or compressed and allows data points that have an intensity of
zero to be omitted. Depending on the number of such data points in the original wiff sample,
this can potentially greatly reduce the size of the MatLab file. This format uses a matrix of size
2 x (total number of (mass, intensity) pairs). The first row represents masses and the second
row the intensities. A given number of initial columns corresponds to the first spectrum, a
given number of following ones to the second spectrum, and so forth. Each (sparse) spectrum
is essentially stored end-to-end.

A separate vector is written, which can be used to determine the starting and ending position
of any given spectrum in this matrix. This vector contains the one-based index of the start of a
given spectrum. The end for a given spectrum can be determined by subtracting one from the
start of the following spectrum (except for the very last spectrum, which is determined by the
size of the above-mentioned matrix).

The first format is the default format for quadrupole spectra and is always used for diode array
data. The second (sparse) format is always used for TOF (time-of-flight) data and can optionally
be used for quadrupole data.

The actual names of the various matrices are specified using the Options dialog described later
in this document.

Use the Script

1. With a chromatogram in an active pane, click Script > Wiff to MatLab.
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Tip! This script can be attached to a batch. Select this script using the Batch Editor.

If the chromatogram is associated with mass spectral data (TIC, XIC), then MS data is
exported to the MatLab file. If the chromatogram is associated with diode array data (TWC,
XWC), then DAD data is exported.

2. (Optional) To change the conversion options, open the Wiff to MatLab Conversion Options
dialog by pressing the Ctrl key while clicking the script.

Otherwise, the options previously specified are used.

Figure 2-41 Wiff to MatLab Conversion Options Dialog
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3. In the Matrix Names fields, type the names of the matrices that the script produces. It is
recommended that these names be kept as the default values.

4. Inthe Threshold for sparse format field, type a value that will be used to reduce the
size of the output MatLab file. For the sparse format only, only (mass/intensity) pairs with
intensity larger than the specified value are written.

If the Save original filename as matrix field is selected, then the script creates and
populates the Filename matrix.

5. To have the quadrupole spectra saved in the sparse format, select the Use sparse format
for quadrupole data check box.

Note: TOF spectra are always saved in the sparse format and that diode array data is
always saved in the non-sparse format.
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If the Save scan times (not scan numbers) field is cleared, then the script populates
the Scans matrix with the time in seconds for each scan. Otherwise, the Scans matrix is
populated with the scan numbers.

6. Inthe Use fixed step size field, type the step size of the data to extract. If this field is
cleared, then the acquisition step size is used.

7. To populate the wavelengths matrix with the DAD data when the script is attached to a
batch, select Save DAD data in batch mode (if available).

8. To save these settings and continue processing the data, click Save.

To discard any changes made to the settings, click Don’t Save. Data processing will
continue after this is clicked.

10. To automatically generate a MatLab file for every sample submitted as part of a batch run
in the Batch Editor, click Select Script to select the script before submitting the batch to
the queue. The script should be located in the Processing Scripts subproject of the API
Instrument project.

A MatLab file is created for every different experiment for each sample in the batch. The
MatLab files are placed in the same location as the data files and will have the same names
with the wiff extension replaced by mat. However, the index of the sample within the wiff

file are appended. In addition, for samples acquired using acquisition methods containing
more than one experiment, the period and experiment number are appended to the MatLab
filename.

For example, if a data file is called test.wiff and contains two samples, then the MatLab files
are called:

¢ test-1.mat

* test-2.mat

If the acquisition method contained one period and two experiments, then four MatLab files
are generated, two for each sample:

o test-1(1,1).mat
+ test-1(1,2
o test-2(1,1
+ test-2(1,2).mat.

mat

).
).
)-mat

).

If the data file contains diode array data and the Save DAD data in batch mode (if
available) check box is selected, then an additional file with the sample index and (DAD)

is created. For the previous example, files called test-1(DAD) and test-2(DAD).mat are
created.
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Known Issues and Limitations

When attaching this script to a batch, make sure that the Acquisition Queue window is open
before submitting the batch. This window must be open until the acquisition has completed to
make sure that the script is working properly.

Related Scripts

Export to JCamp: Converts spectra from wiff format to JCamp format.

Table 2-8 Matrix Definitions

Matrix Dimensions Type Descriptions
Data Number of masses Float The raw intensities for
(or wavelengths) x all of the spectra.
number of scans
SparseData 2 x total number of Double The raw masses (first
(mass, intensity) pairs row) and intensities
(second row) for all
spectra. This matrix
is used only with the
sparse format.
Masses Number of masses x | Float The actual m/z
1 values scanned by
the instrument. This
matrix is only present
when exporting MS
data.
Wavelengths Number of Float The actual
wavelengths x 1 wavelengths acquired
by the diode array
detector. This matrix
is present only when
exporting DAD data.
Index 1 x number of scans |Long N/A
Scans 1 x number of scans | Float The retention times

(in seconds) or the
scan numbers for the
spectra.
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Table 2-8 Matrix Definitions (continued)

Matrix

Dimensions

Type

Descriptions

Filename

1 x length of filename

Text

This optional matrix
specifies the filename
of the original data
file.

XIC from BPC

Use this script to retrieve the list of base peak masses and overlay the corresponding extracted
ion chromatograms (XICs) in an Explore pane below the active pane. Run the XIC from BPC
script after selecting a time region of interest in a chromatogram. The largest peak in each XIC
trace are labeled with its mass if it is greater than 5% of the most intense XIC peak.

Use the Script

Users can optionally select to overlay the XIC traces with an ADC trace. The ADC trace will be
normalized to the most intense XIC trace.

» Select the time region of interest in a chromatogram and do one of the following:

To do this ....

Do this ...

Process the data with current preferences

Click Script > XIC from BPC.

View the script description, set the
processing preferences, and then obtain the
overlaid XIC traces

a. Press Shift and then click Script > XIC
from BPC.

The XIC from Base Peak Masses QS
Description dialog opens.

b. Click Continue.

The XIC From Base Peak Masses
dialog opens. Refer to the figure: Figure
2-42.

Update the processing preferences and then
obtain the overlaid XIC traces

Press Ctrl and then click Script > XIC from
BPC.
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Figure 2-42 XIC From Base Peak Masses Dialog
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After processing starts, a progress bar indicates the current step. When processing is
completed, a new pane with overlaid XIC traces is the active pane. To use the Cycle Overlays
feature when it is unavailable, change the active pane in the software to a different pane and
then reselect the overlaid XIC pane.

XIC from Table

Use this script to create or read start and stop masses from a file. The file must two columns
separated by a tab. The first column must contain the start mass and the second column the
stop mass.

When working with full scan data, the software can show an Extracted lon Chromatogram (XIC)
for a subset of the scanned mass range. If the subsets are repeatedly used on different data,
then it is often convenient to store the subsets of the mass range, consisting of a start and stop
mass, in an external file and have the Analyst software generate an XIC based on this file.

The script generates the requested XICs either as one XIC per pane or with all of the XICs
overlaid in one pane from the current Total lon Chromatogram (TIC).

Use the Script

1. With a TIC open in an active pane, click Script > XIC_from_table.
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Figure 2-43 XIC Preferences Dialog
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2. Using the grid in the dialog, type the mass ranges to be extracted in an XIC.

Tip! To populate the grid from a text file, click File > Open and then browse to the text file.

(Optional) To save the current information in the grid to a file, click File > Save As.
(Optional) To clear the grid of all entries, click Table > Clear.

(Optional) To overlay all of the XICs in a single pane, select Overlay XICs check box.
(

Optional) To create all of the specified XICs, click Extract.

N o o s~

To close the dialog and close the script, click Cancel.

Known Issues and Limitations

» If XIC start/stop masses are not loaded from a text file, then the maximum number of mass
pairs that can be typed is 25. If XIC start/stop masses are loaded from a text file, then an
unlimited number of start/stop mass pairs can be specified.

» Because of the limited space on most monitors, select the Overlay XICs check box when
more than six XICs will be created.
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Addresses

ﬁg;i’;ua ore  ABSciexLLC
250 Forest Street
Marlborough, MA 01752
USA

Customer Training

» Global: sciex.com/contact-us

Online Learning Center

+ SCIEX Now Learning Hub

SCIEX Support

SCIEX and its representatives have a global staff of fully-trained service and technical
specialists. They can supply answers to questions about the system or any technical issues
that might occur. For more information, go to the SCIEX website at sciex.com or use one of the
following links to contact us.

» sciex.com/contact-us

» sciex.com/request-support

Cybersecurity

For the latest guidance on cybersecurity for SCIEX products, visit sciex.com/productsecurity.

Documentation

This version of the document supersedes all of the previous versions of this document.

To find software product documentation, refer to the release notes or software installation guide
that comes with the software.

To find hardware product documentation, refer to the documentation that comes with the system
or component.
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Contact Us

The latest versions of the documentation are available on the SCIEX website, at sciex.com/
customer-documents.

Note: To request a free, printed version of this document, contact sciex.com/contact-us.
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